Hi Bob,

Thanks for the suggestion.  I added 'umask 002' to the tomcat7/bin/startup.sh script.  Sadly it did nothing.  Here are some files from my testing. These are logo files the application receives and stores on disk

-rw-r--r-- 1 tomcat7 tomcat7  17771 Apr 28 14:48 69ff2f84bf5ffa08
-rw-r--r-- 1 tomcat7 tomcat7   6247 Apr 28 14:49 7eeb290334835693
-rw-r--r-- 1 tomcat7 tomcat7  18683 Apr 28 15:02 4c0df621ab060c47

Any other ideas?

Kind regards,


On Thu, Apr 28, 2016 at 3:08 PM, sigzero <sigzero@gmail.com> wrote:
Try setting it in:  tomcat/bin/startup.sh

I think it is just "umask 002" not "umask=002" as well from everything I have seen and read.


On Thu, Apr 28, 2016 at 2:27 PM, Frank <tuxster@gmail.com> wrote:

Ubuntu Server 14.04LTS
Tomcat 7.0.52
Groovy 2.0.8

I have a Groovy application which I run within Tomcat7.  It creates files with permissions of 644 and I would like it to create them with permissions of 664 instead (group read/writable). 

We have a packaged installation of Tomcat7 and we drop our .WAR file in /var/lib/tomcat7/webapps/.  We start the application using the /etc/init.d/tomcat7 script (or `sudo service tomcat7 start`).  We have some other things (like newrelic) which we set to run in a /usr/share/tomcat7/bin/setenv.sh script

I've tried changing the umask setting in the /etc/init.d/tomcat7 script from

umask=022 -to- umask=002

it doesn't affect the permissions on files created by the application. 

Is there a place where I can configure the application itself to create files with these looser default permissions?

Thanks in advance.

Kind regards,