Hi Anto,

did you try again?

I just tried to access https://plugins.gradle.org/m2/gradle/plugin/org/nosphere/apache/creadur-rat-gradle/0.1.3/creadur-rat-gradle-0.1.3.pom and it is available now. I guess if there is no firewall/proxy problem on your side it was just a temporary problem of plugins.gradle.org.

Cheers,
Pascal

Am 10.08.2015 um 15:06 schrieb Owen Rubel:
The output gave you the best advice; run with --stacktrace to see what the issue is

Owen Rubel
415-971-0976
orubel@gmail.com

On Mon, Aug 10, 2015 at 12:14 AM, Anto Aravinth <anto.aravinth.cse@gmail.com> wrote:
Hi Groovy folks, 

I have checked out the groovy from the incubator github. And then I tried running:

 gradle clean dist

I got the following error message:

:buildSrc:compileJava UP-TO-DATE

:buildSrc:compileGroovy UP-TO-DATE

:buildSrc:processResources UP-TO-DATE

:buildSrc:classes UP-TO-DATE

:buildSrc:jar UP-TO-DATE

:buildSrc:assemble UP-TO-DATE

:buildSrc:compileTestJava UP-TO-DATE

:buildSrc:compileTestGroovy UP-TO-DATE

:buildSrc:processTestResources UP-TO-DATE

:buildSrc:testClasses UP-TO-DATE

:buildSrc:test UP-TO-DATE

:buildSrc:check UP-TO-DATE

:buildSrc:build UP-TO-DATE


FAILURE: Build failed with an exception.


* What went wrong:

A problem occurred configuring root project 'groovy'.

> Could not resolve all dependencies for configuration ':classpath'.

   > Could not resolve gradle.plugin.org.nosphere.apache:creadur-rat-gradle:0.1.3.

     Required by:

         :groovy:unspecified

      > Could not GET 'https://plugins.gradle.org/m2/gradle/plugin/org/nosphere/apache/creadur-rat-gradle/0.1.3/creadur-rat-gradle-0.1.3.pom'. Received status code 503 from server: Service Unavailable


* Try:

Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.


BUILD FAILED


Total time: 18.69 secs


Not sure why this is happening. And the gradle version is:


------------------------------------------------------------

Gradle 2.3

------------------------------------------------------------


Build time:   2015-02-16 05:09:33 UTC

Build number: none

Revision:     586be72bf6e3df1ee7676d1f2a3afd9157341274


Groovy:       2.3.9

Ant:          Apache Ant(TM) version 1.9.3 compiled on December 23 2013

JVM:          1.8.0_40 (Oracle Corporation 25.40-b25)

OS:           Mac OS X 10.10.3 x86_64


Kindly let me know where I'm making mistake.