flume-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Divya Gehlot <divya.htco...@gmail.com>
Subject Re: [ERROR:]Phoenix 4.4 Plugin for Flume 1.5
Date Thu, 28 Apr 2016 10:40:22 GMT
Hi Gonzalo,
Thanks for the help.
I am just a day old to Flume

Could you please help me which host/port  do I need to specify ?

Thanks,
Divya



On 28 April 2016 at 18:31, Gonzalo Herreros <gherreros@gmail.com> wrote:

> Seems your agent config file doesn't specify the host/port for the Sink
>
> Gonzalo
>
> On 28 April 2016 at 11:13, Divya Gehlot <divya.htconex@gmail.com> wrote:
>
>> Hi,
>> I am trying to move data from hdfs to Phoenix
>> I downloaded the https://github.com/forcedotcom/phoenix/
>> and build the project as per instrunctions in Apache Phoenix site.
>> and placed the phoenix-3.0.0-SNAPSHOT-client.jar in
>> /flume/lib/phoenix-3.0.0-SNAPSHOT-client.jar
>>
>> and When I am ruuning Flume
>>
>>> bin/flume-ng agent -n phoenix-agent -c conf/ -f conf/phoenix-agent.conf
>>> -Dflume.root.logger=DEBUG,console
>>
>>
>> getting below error
>>
>>  [ERROR -
>>> org.apache.flume.lifecycle.LifecycleSupervisor$MonitorRunnable.run(LifecycleSupervisor.java:253)]
>>> Unable to start SinkRunner: {
>>> policy:org.apache.flume.sink.DefaultSinkProcessor@71060c3e
>>> counterGroup:{ name:null counters:{} } } - Exception follows.
>>> java.lang.IllegalArgumentException: Not a host:port pair: PBUF
>>
>>
>> Can any body help me in resolving the error .
>> Would really appreciate the help.
>>
>>
>> Thanks,
>> Divya
>>
>>
>>
>>
>

Mime
View raw message