flume-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hari Shreedharan <hshreedha...@cloudera.com>
Subject Re: Flume Compile 1.5.0 for HBase 0.98.3
Date Sun, 27 Jul 2014 01:26:44 GMT
Looks like you are trying to build flume-1.5.0. To build with hbase-98
support, you need to either checkout trunk branch or the release-1.5.0.1
tag (that release was specifically meant to add hbase-98 support).

Hari

On Sat, Jul 26, 2014 at 5:05 PM, ac@hsk.hk <ac@hsk.hk> wrote:

> Hi,
>
> Tried:
>
> mvn clean install -Dhadoop.profile=hbase-98 -Dhbase.version=0.98.3
> [INFO] Scanning for projects...
> [ERROR] The build could not read 3 projects -> [Help 1]
> [ERROR]
> [ERROR]   The project
> org.apache.flume.flume-ng-sinks:flume-hdfs-sink:1.5.0 (
> flume-ng-sinks/flume-hdfs-sink/pom.xml) has 2 errors
> [ERROR]     'dependencies.dependency.artifactId' for org.apache.hadoop:${
> hadoop.common.artifact.id}:jar with value '${hadoop.common.artifact.id}'
> does not match a valid id pattern. @ line 89, column 19
> [ERROR]     'dependencies.dependency.version' for org.apache.hadoop:${
> hadoop.common.artifact.id}:jar is missing. @ line 87, column 17
> [ERROR]
> [ERROR]   The project
> org.apache.flume.flume-ng-sinks:flume-ng-hbase-sink:1.5.0 (
> flume-ng-sinks/flume-ng-hbase-sink/pom.xml) has 2 errors
> [ERROR]     'dependencies.dependency.artifactId' for org.apache.hadoop:${
> hadoop.common.artifact.id}:jar with value '${hadoop.common.artifact.id}'
> does not match a valid id pattern. @ line 96, column 19
> [ERROR]     'dependencies.dependency.version' for org.apache.hadoop:${
> hadoop.common.artifact.id}:jar is missing. @ line 94, column 17
> [ERROR]
> [ERROR]   The project org.apache.flume:flume-ng-tests:1.5.0 (
> flume-ng-tests/pom.xml) has 2 errors
> [ERROR]     'dependencies.dependency.artifactId' for org.apache.hadoop:${
> hadoop.common.artifact.id}:jar with value '${hadoop.common.artifact.id}'
> does not match a valid id pattern. @ line 60, column 19
> [ERROR]     'dependencies.dependency.version' for org.apache.hadoop:${
> hadoop.common.artifact.id}:jar is missing. @ line 58, column 17
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the
> -e switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions,
> please read the following articles:
> [ERROR] [Help 1]
> http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
>
>
>
> Are there something wrong in default pom.xml files?
>
> flume-ng-sinks/flume-hdfs-sink/pom.xml @ line 89
>     <dependency>
>       <groupId>org.apache.hadoop</groupId>
>       <artifactId>${hadoop.common.artifact.id}</artifactId>
>       <optional>true</optional>
>     </dependency>
>
> flume-ng-sinks/flume-ng-hbase-sink/pom.xml   @ line 96,
>     <dependency>
>       <groupId>org.apache.hadoop</groupId>
>       <artifactId>${hadoop.common.artifact.id}</artifactId>
>       <optional>true</optional>
>     </dependency>
>
> flume-ng-tests/pom.xml  @ line 58
>     <dependency>
>       <groupId>org.apache.hadoop</groupId>
>       <artifactId>${hadoop.common.artifact.id}</artifactId>
>       <optional>true</optional>
>     </dependency>
>
>
> Many thanks!
> Arthur
>
>
>
>
>
>
>
>
> Also tried:
> mvn clean install -Dhadoop.profile=hbase-98 -Dhbase.version=0.98.3-hadoop2
> [INFO] Scanning for projects...
> [ERROR] The build could not read 3 projects -> [Help 1]
> [ERROR]
> [ERROR]   The project
> org.apache.flume.flume-ng-sinks:flume-hdfs-sink:1.5.0
> (flume-ng-sinks/flume-hdfs-sink/pom.xml) has 2 errors
> [ERROR]     'dependencies.dependency.artifactId' for org.apache.hadoop:${
> hadoop.common.artifact.id}:jar with value '${hadoop.common.artifact.id}'
> does not match a valid id pattern. @ line 89, column 19
> [ERROR]     'dependencies.dependency.version' for org.apache.hadoop:${
> hadoop.common.artifact.id}:jar is missing. @ line 87, column 17
> [ERROR]
> [ERROR]   The project
> org.apache.flume.flume-ng-sinks:flume-ng-hbase-sink:1.5.0
> (flume-ng-sinks/flume-ng-hbase-sink/pom.xml) has 2 errors
> [ERROR]     'dependencies.dependency.artifactId' for org.apache.hadoop:${
> hadoop.common.artifact.id}:jar with value '${hadoop.common.artifact.id}'
> does not match a valid id pattern. @ line 96, column 19
> [ERROR]     'dependencies.dependency.version' for org.apache.hadoop:${
> hadoop.common.artifact.id}:jar is missing. @ line 94, column 17
> [ERROR]
> [ERROR]   The project org.apache.flume:flume-ng-tests:1.5.0
> (flume-ng-tests/pom.xml) has 2 errors
> [ERROR]     'dependencies.dependency.artifactId' for org.apache.hadoop:${
> hadoop.common.artifact.id}:jar with value '${hadoop.common.artifact.id}'
> does not match a valid id pattern. @ line 60, column 19
> [ERROR]     'dependencies.dependency.version' for org.apache.hadoop:${
> hadoop.common.artifact.id}:jar is missing. @ line 58, column 17
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the
> -e switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions,
> please read the following articles:
> [ERROR] [Help 1]
> http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
>
>
>
>
>
>

Mime
View raw message