flume-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sanjay Ramanathan <sanjay.ramanat...@lucidworks.com>
Subject Morphlines: getting the error "unclosed quotation" although handled
Date Fri, 18 Jul 2014 01:50:30 GMT
Hi,


Firstly, sorry for inundating you with queries every other day.


While trying to push data into Solr from a TSV file using Flume/Morphlines.

I'm getting the error


"Unable to deliver event

Caused by: org.kitesdk.morphline.api.MorphlineRuntimeException: java.lang.IllegalStateException:
unexpected end of file, unclosed quotation
"

My morphline.conf file has the following properties:
"
readCSV {
          separator : "\t"
          columns : [parcelid,propertyaddress,streetnumber,streetdirection,streetname,streettype,unitnumber,heatedarea,bedrooms,bathrooms,book,page,instrumentnumber,pid,link,mailingaddress1,mailingaddress2,mailingaddresscity,mailingaddresscountry,mailingaddressstate,mailingaddresszip,buyers,sellers,saleamount,saledescriptioncode,saledescription,averageyearbuilt,dateofsale,propertyusecode,numberofbuildings,propertyusetype]
          ignoreFirstLine : false
          quoteChar : "\""
          commentPrefix : " "
          trim : true
          charset : UTF-8

      }
"
I've tried commentPrefix with "" "#" " "
I've tried trim with true and false.

I'm using the flume 1.5.0. The kite-morphlines jars in the lib folder are 0.12.0 version.

I've attached the TSV file(POCSampleData-2.txt).


I don't think there is anything wrong with the flume.conf file as it pushes data properly
into Solr, if the records with quotes are removed.


Thanks in advance.


Sincerely,

Sanjay Ramanathan


Mime
View raw message