flume-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From César Monteserín <cmontese...@stratio.com>
Subject Re: Some dependencies can not be found in 1.5.0 release
Date Thu, 29 May 2014 14:54:28 GMT
It is good to know that,

thank you!


2014-05-28 20:45 GMT+02:00 Wolfgang Hoschek <whoschek@cloudera.com>:

> There is no backwards incompatible change in the code regardless of
> whether it's kite 0.10 or 0.11 or 0.12 or 0.13 or 0.14. The dependencies
> have been made “optional” in
> flume-ng-sinks/flume-ng-morphline-solr-sink/pom.xml via
> <optional>true</optional>, thus the dependencies don’t ship automatically
> with the build.
>
> Here is a flume-centric way of getting hold of all the jars:
> https://groups.google.com/a/cloudera.org/d/msg/cdk-dev/7T4pTebdWN4/sBHGkoS70LkJ
>
> Wolfgang.
>
> On May 28, 2014, at 12:11 PM, Iván Fernández Perea <
> ivan.fernandez.perea@gmail.com> wrote:
>
> > It seems that flume has updated kite to 0.12 version
> > http://flume.apache.org/releases/1.5.0.html
> > https://issues.apache.org/jira/browse/FLUME-2345
> >
> > So flume doesnt use lastest kite version and probably does not use this
> class anymore org/kitesdk/morphline/api/Command. What kite version are you
> using?
> >
> > Regards
> >
> >
> > 2014-05-28 10:47 GMT+02:00 César Monteserín <cmonteserin@stratio.com>:
> > Hi Iván,
> >
> > the MorphlineInterceptor class belongs to the Solr sink that comes with
> flume.
> >
> > If I add the Kite, Metrics and Config dependencies, the
> NoClassDefFoundError error dissappears. However, I did not have to add any
> dependency in the previous version.
> >
> > Thank you.
> >
> >
> > 2014-05-28 10:04 GMT+02:00 Iván Fernández Perea <
> ivan.fernandez.perea@gmail.com>:
> >
> > Hi Cesar,
> >
> > check if ou have MorphlineInterceptor within your flume classpath
> (FLUME_CLASSPATH variable in flume-env.sh file)
> >
> >
> >
> >
> > 2014-05-28 9:55 GMT+02:00 César Monteserín <cmonteserin@stratio.com>:
> >
> > Hi,
> >
> > I am getting the following error:
> >
> > [ERROR -
> org.apache.flume.node.PollingPropertiesFileConfigurationProvider$FileWatcherRunnable.run(PollingPropertiesFileConfigurationProvider.java:145)]
> Failed to start agent because dependencies were not found in classpath.
> Error follows.
> > java.lang.NoClassDefFoundError: org/kitesdk/morphline/api/Command
> >     at
> org.apache.flume.sink.solr.morphline.MorphlineInterceptor.<init>(MorphlineInterceptor.java:55)
> >     at
> org.apache.flume.sink.solr.morphline.MorphlineInterceptor$Builder.build(MorphlineInterceptor.java:112)
> >     at
> org.apache.flume.sink.solr.morphline.MorphlineInterceptor$Builder.build(MorphlineInterceptor.java:103)
> >     at
> org.apache.flume.channel.ChannelProcessor.configureInterceptors(ChannelProcessor.java:111)
> >     at
> org.apache.flume.channel.ChannelProcessor.configure(ChannelProcessor.java:80)
> >     at
> org.apache.flume.conf.Configurables.configure(Configurables.java:41)
> >     at
> org.apache.flume.node.AbstractConfigurationProvider.loadSources(AbstractConfigurationProvider.java:353)
> >     ...
> >
> > The configuration of the morphline interceptor is:
> >
> > agent.sources.spoolSource.interceptors = morphlineinterceptor
> > agent.sources.spoolSource.interceptors.morphlineinterceptor.type =
> org.apache.flume.sink.solr.morphline.MorphlineInterceptor$Builder
> >
> agent.sources.spoolSource.interceptors.morphlineinterceptor.morphlineFile =
> {morphline_file}
> > agent.sources.spoolSource.interceptors.morphlineinterceptor.morphlineId
> = morphline1
> >
> > Thanks in advance
> >
> >
> > 2014-05-28 5:11 GMT+02:00 Otis Gospodnetic <otis.gospodnetic@gmail.com>:
> >
> > Hi,
> >
> > Maybe you can provide some more information about errors you are seeing
> when you do ____ and somebody may be able to help.
> >
> > Otis
> > --
> > Performance Monitoring * Log Analytics * Search Analytics
> > Solr & Elasticsearch Support * http://sematext.com/
> >
> >
> > On Mon, May 26, 2014 at 7:23 AM, César Monteserín <
> cmonteserin@stratio.com> wrote:
> > Hi,
> >
> > I am trying to use a morphline interceptor with no success.
> > The same configuration works with the previous version, the 1.4.0.
> >
> > It seems that several dependencies can not be found such as Kite,
> Metrics and Config.
> >
> > Could you take a look at it?
> >
> > Thank you
> >
> >
> >
> >
> >
> > --
> > Visit my blog:
> > http://java4developers.com/
> >
> >
> >
> >
> > --
> > Visit my blog:
> > http://java4developers.com/
>
>

Mime
View raw message