The people on my side who take care of our Hadoop infrastructure are certain IBM won't support infrastructure touched by 1.4. We might be able to get away with using the JMS component as a custom source and leave our SLA intact

On Mar 13, 2014 5:32 PM, "Kris Ogirri" <kanirip@gmail.com> wrote:
I am not certain how performing the update to Flume violate any Service contract one could have with IBM but I am certain that Flume 1.3 has a significant amount of issues with Hbase connectivity. You might have to discuss the legal implications with your IBM Sales Rep or Business Partner.( Disclaimer: I work for IBM)


On 13 March 2014 23:19, Christopher Shannon <cshannon108@gmail.com> wrote:

Kris,

How does running Flume 1.4 affect your service contract with IBM?

On Mar 13, 2014 5:02 PM, "Kris Ogirri" <kanirip@gmail.com> wrote:
Hello Christoper,

I believe the latest versions of BigInsights  does come with Flume 1.3 but I have been able to successfully upgrade Flume within BigInsights to the most recent version I know of ( 1.4). The steps are straight-forward.

1) Download the flume v1.4 binary tarball from the Apache Flume site.
2) Perform a backup of the 'bin' , 'lib', 'docs','conf' directory in $BIGINSIGHTS_HOME/flume/ ( I basically renamed these directories appending a 13 to their names)
3) Explode the Apache Flume Tarball into any other directory in your environment ( $HOME/flume140 probably)
4) Copy over the 'bin' , 'lib', 'docs','conf' and 'tools' directory from your Flume 1.4 directory into your $BIGINSIGHTS_HOME/flume/  ( or /opt/ibm/biginsights/flume)
5) Test flume functionality by executing the following command in the 'bin' directory ' ./flume-ng version'

If everything goes right you should see that flume is updated to version 1.4.

Try it out and let us know how it goes,



On 13 March 2014 22:48, Christopher Shannon <cshannon108@gmail.com> wrote:

IBM Big Insights.

On Mar 13, 2014 4:47 PM, "Brock Noland" <brock@cloudera.com> wrote:
I think it should work to run the 1.4 JMS source in 1.3.

Out of curiosity, which vendor isn't shipping 1.4?

Brock


On Thu, Mar 13, 2014 at 4:43 PM, Christopher Shannon <cshannon108@gmail.com> wrote:

I know that the JMS source is new in version 1.4, but has anyone tried running this particular component on Flume 1.3.x? I can"t upgrade to 1.4 because of vendor lock-in. And I am condidering rolling my own JMS source for 1.3 if the source for 1.4 won't work.

Any thoughts or recommendations?