I just hope you are not hitting this https://issues.apache.org/jira/browse/FLUME-796
I would also like to recommend you to upgraded to flume 1.x asap 

if possible can you try changing your flume source to some random file with tail -f and try sinking it to some file. That will narrow the problem is on flume side or terracotta side 

Thanks,
Nitin 


On Mon, Dec 10, 2012 at 1:47 PM, <shouvanik.haldar@accenture.com> wrote:

Hi,

 

I am using Flume -> Flume 0.9.4-cdh3u5.

 

Initially, the logs are ok. But when I start terracotta (./start-tc-server.sh) , then only I experience the above phenomena! Is it something to do with terracotta.!

 

 

2012-12-10 03:14:08,806 INFO com.cloudera.flume.handlers.thrift.ThriftEventSource: Starting blocking thread pool server on port 35853...

2012-12-10 03:14:08,894 INFO net.sf.ehcache.terracotta.TerracottaClient: Thread [logicalNode ec2-75-101-165-36.compute-1.amazonaws.com-19] [cacheManager: 'RTLogCacheManager']: Creating new ClusteredInstanceFactory

 

Before starting terracotta, Flume Node status is “OPENING”.

But when I start terracotta, I got the error “INFO com.cloudera.flume.watchdog.Watchdog: Subprocess exited with value 1”

 

Please help !

 

 

Thanks and Regards,

Shouvanik Haldar | Cloud SME Pool | Mobile:+91-9830017568

 

From: Nitin Pawar [mailto:nitinpawar432@gmail.com]
Sent: Monday, December 10, 2012 12:52 PM
To: user@flume.apache.org
Cc: Haldar, Shouvanik
Subject: Re: Getting weird error -> 2012-12-10 01:01:42,190 INFO com.cloudera.flume.watchdog.Watchdog: Subprocess exited with value 1

 

what version of flume are you using? If it is < 1.x then recommend you to upgrade to latest 1.0.3 

If you are on 1.x then can you tell us whats the hostname for your server? 

 

On Mon, Dec 10, 2012 at 11:40 AM, <shouvanik.haldar@accenture.com> wrote:

Before the below mentioned error, I get a success message like

 

2012-12-10 01:09:14,403 INFO net.sf.ehcache.terracotta.TerracottaClient: Thread [logicalNode ec2-75-101-165-36.compute-1.amazonaws.com-19] [cacheManager: 'RTLogCacheManager']: Creating new ClusteredInstanceFactory

 

Thanks and Regards,

Shouvanik Haldar | Cloud SME Pool | Mobile:+91-9830017568

 

From: Haldar, Shouvanik
Sent: Monday, December 10, 2012 11:34 AM
To: 'user@flume.apache.org'
Subject: Getting weird error -> 2012-12-10 01:01:42,190 INFO com.cloudera.flume.watchdog.Watchdog: Subprocess exited with value 1

 

I had configured flume-master as well as flume-node on a single machine.

Now, as I run terracotta -> L1 cache, I get the INFO below in /

 

2012-12-10 01:01:42,190 INFO com.cloudera.flume.watchdog.Watchdog: Subprocess exited with value 1

 

Can you please help? I am struggling with this for the past 1 day without success!

 

Thanks and Regards,

Shouvanik Haldar | Cloud SME Pool | Mobile:+91-9830017568

 

 


This message is for the designated recipient only and may contain privileged, proprietary, or otherwise private information. If you have received it in error, please notify the sender immediately and delete the original. Any other use of the e-mail by you is prohibited.

Where allowed by local law, electronic communications with Accenture and its affiliates, including e-mail and instant messaging (including content), may be scanned by our systems for the purposes of information security and assessment of internal compliance with Accenture policy.

______________________________________________________________________________________

www.accenture.com



 

--
Nitin Pawar




--
Nitin Pawar