flume-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From alo alt <wget.n...@googlemail.com>
Subject Re: Flume-0.9.4 with Hadoop-1.0.0/HBase-0.92.0
Date Tue, 06 Mar 2012 10:28:28 GMT
Ah, I missed that. 0.23 will be hadoop 2.0... wrong reading
Hadoop 1.0 >= 0.20.205.1

http://www.cloudera.com/blog/2012/01/an-update-on-apache-hadoop-1-0/
http://www.cloudera.com/blog/2012/01/hadoop-in-2011/

Flume .94 is build against  0.20.2+710, which  include all patches as hadoop-1.0 and should
run with. To build it you could use the maven repo from cloudera:
https://repository.cloudera.com/artifactory/cloudera-repos

Back to the main question:
@Sonja: Could you please post a log snippet with the error? I think it depends on the hbase
upgrade (flume sink isn't compatible) and has nothing to do with the hdfs version. 

- Alex

--
Alexander Lorenz
http://mapredit.blogspot.com

On Mar 6, 2012, at 3:59 AM, lulynn_2008 wrote:

> Hi Alex,
> I got it that flume-0.9.4 can not be compatible with hadoop-1.0.0.
> Could you please explain why?
> 
> 
> At 2012-03-05 20:06:24,"alo alt" <wget.null@googlemail.com> wrote:
> >Hi Sonja,
> >
> >yes.
> >But in https://issues.apache.org/jira/browse/FLUME-937 a patch still exists, the
maven repo _should_ be available, I think :)
> >
> >best,
> > Alex 
> >
> >--
> >Alexander Lorenz
> >http://mapredit.blogspot.com
> >
> >On Mar 5, 2012, at 12:17 PM, Sonia Matamoros Rivero wrote:
> >
> >> Hi,
> >> 
> >> Does it mean that Flume is compatible with Hadoop-0.20.x but isn't with Hadoop-1.0.0?
> >> 
> >> Thanks!
> >> 
> >> Sonia
> >> 
> >> El 5 de marzo de 2012 10:30, alo alt <wget.null@googlemail.com> escribió:
> >> Hi,
> >> 
> >> yes. Flume is build agains a version of HDFS and upwards compatible, but not
forward. You'll see messages like Protocol org.apache.hadoop.hdfs.protocol.ClientProtocol
version mismatch in the log.
> >> You can download the source and build flume 0.94 against your new hadoop installation.
> >> 
> >> best,
> >>  Alex
> >> 
> >> --
> >> Alexander Lorenz
> >> http://mapredit.blogspot.com
> >> 
> >> On Mar 5, 2012, at 10:16 AM, Sonia Matamoros Rivero wrote:
> >> 
> >> > Hi!
> >> >
> >> > We are using Flume to recollect data from logs and to store them into HBase.
We are using the Flume-0.9.4. This version works perfectly with Hadoop-0.20 and HBase-0.90.3.
> >> > A few days ago we have upgraded Hadoop to 1.0.0 version and HBase to 0.92.0.
Now, Flume is not able to connect to HBase. Is there any version incompatibility?
> >> >
> >> > Thanks in advance,
> >> >
> >> > Sonia
> >> >
> >> 
> >> 
> >
> 
> 
> 


Mime
View raw message