flume-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bharath Ravi <bharathra...@gmail.com>
Subject Piping stdin into flume shell does not work
Date Mon, 19 Mar 2012 20:31:47 GMT
Hi all,

The user guide<http://archive.cloudera.com/cdh/3/flume/UserGuide/#_using_the_flume_command_shell>
says
it is possible to pipe stdin into flume shell.
This does not work for me. Manually logging into the shell and running the
same commands works perfectly fine.
Any pointers as to what might be going wrong? Here's a command I tried with
its output:


# echo "connect fm-vm-010.cercs.int\nexec unconfig fm-vm-011.cercs.int" |
./bin/flume shell
2012-03-19 16:31:05,768 [main] INFO conf.FlumeConfiguration: Loading
configurations from conf
==================================================
FlumeShell v0.9.4
Copyright (c) Cloudera 2010, All Rights Reserved
==================================================
Type a command to execute (hint: many commands
only work when you are connected to a master node)

You may connect to a master node by typing:
    connect host[:adminport=35873[:reportport=45678]]

[flume (disconnected)] connect fm-vm-010.cercs.int\nexec unconfig
fm-vm-011.cercs.int
Failed to run command 'connect fm-vm-010.cercs.int\nexec unconfig
fm-vm-011.cercs.int' due to null
2012-03-19 16:31:06,149 [main] ERROR util.FlumeShell: Failed to run command
'connect fm-vm-010.cercs.int\nexec unconfig fm-vm-011.cercs.int'

Mime
View raw message