flume-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bharath Ravi <bharathra...@gmail.com>
Subject Re: Exception on opening a "Stub Source" at a logical node
Date Thu, 22 Mar 2012 14:06:59 GMT
Hi,

I've with both the default as well as custom named flows:
this doesn't happen all the time, but it does happen frequently.
I'm trying to figure out a pattern to this: has anyone encountered this
before?

This is in flume-0.9.4 and doesn't occur in 0.9.2, so I wonder if it has
something to do
with https://issues.apache.org/jira/browse/FLUME-626

Thanks!
--
Bharath Ravi



On 21 March 2012 03:46, alo alt <wget.null@googlemail.com> wrote:

> Hi,
>
> they are in the default-flow or did you define a other one?
>
> - Alex
>
> --
> Alexander Lorenz
> http://mapredit.blogspot.com
>
> On Mar 21, 2012, at 12:30 AM, Bharath Ravi wrote:
>
> > Hi all,
> >
> > I have a logical node, that uses an 'autoCollectorSource'. I configure
> this node before mapping it to an actual physical node.
> > However, configuring it causes this to happen:
> >
> > 012-03-20 19:25:24,927 ERROR
> com.cloudera.flume.core.connector.DirectDriver: Closing down due to
> exception on open calls
> > 2012-03-20 19:25:24,927 INFO
> com.cloudera.flume.core.connector.DirectDriver: Connector logicalNode
> hadoop-collector-21 exited with error: Attempting to open a Stub Source!
> >
> > What causes this error? Even if it is a stub source, shouldn't it wait
> until it receives an actual source instead of exiting?
> > After all, a logical node is especially meant for cases where
> configuring it can be done before mapping it on to a node!
> >
> > What am I messing up? Is there a specific order in which
> unmap/config/map must be done for a logical node?
> >
> > Thanks!
> > --
> > Bharath Ravi
> >
>
>

Mime
View raw message