flume-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lulynn_2008 <lulynn_2...@163.com>
Subject Re:Re: flume-0.9.1: can not saving current configuration to "filename" by " exec save 'filename' "
Date Mon, 12 Mar 2012 08:45:56 GMT
Yes.
And the result indicate SUCCEED, but actually save the configuration to default file set in
flume-conf.xml:
[flume localhost:35873:45678] exec save '/home/flume-user/flume/current.flume'
[id: 12] Execing command : save
Command succeeded

LOG in flumemaster.log:
2012-03-12 01:41:10,643 [exec-thread] INFO master.CommandManager: Executing command: save
[/home/flume-user/flume/current.flume]
2012-03-12 01:41:10,644 [exec-thread] INFO master.ConfigManager: Saving configuration to:
/home/flume-user/conf/current.flume







At 2012-03-12 15:22:46,"alo alt" <wget.null@googlemail.com> wrote:
>Are the configured directory writable by the flume user?
>
>best,
> Alex
>
>--
>Alexander Lorenz
>http://mapredit.blogspot.com
>
>On Mar 12, 2012, at 2:24 AM, lulynn_2008 wrote:
>
>> This did not happen in flume-0.9.1 with same configuration.
>> 
>> flume-conf.xml:
>>   <property>
>>     <name>flume.master.savefile</name>
>>     <value>conf/current.flume</value>
>>     <description>Node configurations can be saved to this file, and
>>     reloaded at startup.
>>     </description>
>>   </property>
>> 
>> 
>> 
>> At 2012-03-10 06:13:14,"Jay Stricks" <jay@wapolabs.com> wrote:
>> Check your flume-conf.xml or flume-site.xml file for the value for flume.master.savefile.
 Also check the master's web interface under the Static Configuration link to see what it
is with the current setup.
>> 
>> 2012/3/9 lulynn_2008 <lulynn_2008@163.com>
>> BTW, during "exec save", which file flume read the configuration from?
>> 
>> 
>> -------- Forwarding messages --------
>> From: lulynn_2008 <lulynn_2008@163.com>
>> Date: 2012-03-09 17:06:33
>> To: flume-user@incubator.apache.org
>> Subject: flume-0.9.1: can not saving current configuration to "filename" by " exec
save 'filename' "
>>  Hi,
>> 
>> I connect flume master by "./flume shell -c localhost:35873"
>> Then "exec save '/home/flumeUser/flume/current.flume' " The result show "Command
succeeded". 
>> But the configuration is not loaded to /home/flumeUser/flume/current.flume, but to
default file name /home/flumeUser/conf/current.flume. 
>> Could you exlaination why th is happened? Thank you.
>> 
>> 
>> Here is the information from flumemaster.out:
>> 2012-03-09 00:54:28,746 [pool-2-thread-1] INFO master.CommandManager: Submitting
command: save [/home/flumeUser/flume/current.flume]
>> 2012-03-09 00:54:28,749 [exec-thread] INFO master.CommandManager: Executing command:
save [/home/flumeUser/flume/current.flume]
>> 2012-03-09 00:54:28,749 [exec-thread] INFO master.ConfigManager: Saving configuration
to: /home/flumeUser/conf/current.flume
>> 
>> This default file is set by flume-conf.xml:
>>   <property>
>>     <name>flume.master.savefile</name>
>>     <value>conf/current.flume</value>
>>     <description>Node configurations can be saved to this file, and
>>     reloaded at startup.
>>     </description>
>>   </property>
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>

Mime
View raw message