flume-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Strishock <thre...@gmail.com>
Subject Oddities with hostname on a few mappings?
Date Thu, 13 Oct 2011 04:07:33 GMT
In one of the sets of servers that I'm attempting to configure, I've
noticed that during installation the hostname was set differently then
the others, so flume is displaying

aaa-bb-ccc103.int.domain.com as opposed to just the aaa-bb-cc103 hostname

I didn't really thing about it until I rolled out the configs to this
set of boxes, and noticed that the configuration wasn't taking... I've
tried a few different variants of the hostname, putting single quotes
around it, etc, nothing seems to be working.

I toss it out to the group, thoughts on why having a FQDN in the
hostname would matter to the flume master?



exec map aaa-bb-ccc103 ccc103-something.log
exec config ccc103-poller.log 'flow-something.log' 'exec("tail -n +0
-F /var/log/project/something.log")'  'agentE2ESink("flume1", 35854)'


vs


exec map aaa-bb-ccc103.int.domain.com ccc103-something.log
exec config ccc103-poller.log 'flow-something.log' 'exec("tail -n +0
-F /var/log/project/something.log")'  'agentE2ESink("flume1", 35854)'


I end up receiving:
FAILED	map [aaa-bb-ccc103.int.domain.com, ccc103-something.log]	Unable
to map logical node 'ccc103-something.log' to physical node
'aaa-bb-ccc103.int.domain.com'

Are my tired eyes missing something obvious? :) (same error 0.9.4 CDH
or 0.9.5 fresh build from trunk)
-- kev

Mime
View raw message