celix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Björn Petri <bjoern.pe...@sundevil.de>
Subject Re: celix log levels
Date Fri, 13 Dec 2013 09:04:18 GMT

>> So I'd like to propose to use the Bundle constants as an example and 
>> do
>> the
>> same for the others. This would make the LogService constants to be:
>> * OSGI_SERVICE_LOG_LOGSERVICE_DEBUG --> This still has a 
>> duplication, but
>> removing this might result in conflicts if within one package 
>> multiple
>> Classes use the same constant names.
>
> This doesn't improve readability of the code and I personally think 
> that
> it is not likely to happen. And following the reasoning, what if the
> external library is a OSGI library? That might still lead to 
> problems. So
> personally i am against it.

I agree. In my opinion, having the {NAME}_{VALUE} (e.g. 
LOGSERVICE_LOG_DEBUG) solution
should be sufficient.

Regards,
   Bjoern




Mime
View raw message