archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fredrik Jonson <>
Subject Not able to login with admin account after upgrade to 2.2.3 (SOLVED)
Date Wed, 19 Jul 2017 10:39:29 GMT
Hi all,

Just a quick note, should someone else stumble on this issue in the uture.

After upgrading a archiva instance to 2.2.3 from 1.3.9, I found that I was
unable to log in with the default admin account. All other accounts worked

After digging around a bit I found a quite subtle log statement in

  INFO - user admin not validated

Indeed, checking the user database, there's a column 'validated' in the
sa.jdouser table, and the value was 'N' for username 'admin'.

To fix it I used Derby interactive client ij,  and changed the value to 'Y',
using the following commands:

   connect 'jdbc:derby:data/databases/users';
   update sa.jdouser set validated = 'Y' where username = 'admin';

After that, it was possible to log in with the admin account again.

Is it possible that the 1.3.x-versions of Archiva didn't enforce the
validated attribute? Or does a reset password request set it to 'N'?
Otherwise I cannot explain why it was 'N' after the upgrade, and why
I was able to log in with the admin account before the upgrade to 2.2.3.

Anyhow, apart from this the upgrade to 2.2.3 was easy and frictionless.

Thank you to developers and the community at large for continued efforts
to maintain Archiva, a repository manager that just works!

cheers / fredrik

View raw message