archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olivier Lamy <ol...@apache.org>
Subject Re: Upgrading from ancient 1.3.6 to 2.2.1
Date Mon, 20 Jun 2016 23:53:55 GMT
Hi
Does the directory exists? /data/jcr

Well there is no migration, only the first scan will be a bit longer.

On 21 June 2016 at 04:14, Jörg Schaible <joerg.schaible@gmx.de> wrote:

> Hi folks,
>
> since the old version refuses to run with Java 8, I finally tried to
> upgrade
> Archiva from version 1.3.6 to 2.2.1 (as WAR in Tomcat 8). The webapp does
> not start up now because of the nested exception:
>
> ================== %< ====================
> nested exception is
> org.apache.jackrabbit.core.config.ConfigurationException: Invalid workspace
> root directory: /data/jcr/workspaces
> ================== %< ====================
>
> I already learned that Jackrabbit was introduced with version 1.4. However,
> it seems any (migration) documentation is no longer available due to
> security issues: http://archiva.apache.org/versions.html
>
> ;-)
>
> Any pointer?
>
> - Jörg
>
>


-- 
Olivier Lamy
http://twitter.com/olamy | http://linkedin.com/in/olamy

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message