archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paththamestrige Perera <prasad.srimal.per...@gmail.com>
Subject Download Artifacts from ivy repository fails
Date Mon, 08 Feb 2016 18:13:24 GMT
Hello All,

I'm a new user to Apache Archiva and I'm currently setting up Archiva 2.2.0
to manage asa  remote proxy server for an application built with sbt.
 I have added https://repo.typesafe.com/typesafe/ivy-releases/ as a remote
repository in Archiva but my sbt build fails with following messages:

[debug] local: no ivy file found for org.scala-lang#scala-compiler;2.10.4
[debug] tried
http://localhost:8080/internal/org.scala-lang/scala-compiler/2.10.4/ivys/ivy.xml
[debug] CLIENT ERROR: Not Found url=
http://localhost:8080/internal/org.scala-lang/scala-compiler/2.10.4/ivys/ivy.xml
[debug] my-ivy-proxy-releases: no ivy file found for
org.scala-lang#scala-compiler;2.10.4
[debug] tried
http://localhost:8080/repository/internal/org/scala-lang/scala-compiler/2.10.4/scala-compiler-2.10.4.pom

 Also from Archiva side, I see following logs:

 [08/Feb/2016:17:50:59 +0000] "HEAD
/internal/org.scala-lang/scala-compiler/2.10.4/ivys/ivy.xml HTTP/1.1" 404
1423 "-" "Apache Ivy/2.3.0"

I can't figure out why these artifacts are not downloaded. When I try
accessing them directly,
they are available at https://repo.typesafe.com/typesafe/ivy-releases/
Can someone enlighten me on this problem ?

Thanks!

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message