archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wes Wannemacher <w...@wantii.com>
Subject Re: unable to get LDAP/Roles Mapping to work in 2.2.0
Date Thu, 07 May 2015 20:17:51 GMT
I've been trying to troubleshoot this issue and I'm having trouble
following the flow of execution. I've set breakpoints in
DefaultLdapGroupMappingService and DefaultLdapRoleMapperConfiguration.
Neither one of the breakpoints is reached when I try to save the Ldap
Group -> Archiva Role mapping. Could the problem be in the Javascript?
I'm not sure how to troubleshoot issues in the Javascript.

Thanks again for your help.

-Wes

On Wed, May 6, 2015 at 11:28 PM, Wes Wannemacher <wesw@wantii.com> wrote:
> Hello,
>
> I am new to archiva. I have LDAP working so that I can login with LDAP
> accounts onto my server. Also, when I am in the LDAP/Roles Mapping
> screen, the LDAP groups appear correctly in the LDAP Groups dropdown.
> However, if I setup a mapping and click the Save button, the mapping
> will be gone by the time I leave the screen and come back.
> Additionally, the mapping does not work (members of the LDAP group are
> not granted the Role that I mapped). I have tried creating a
> security.properties file with the following contents (per the redback
> docs):
>
> ldap.config.groups.role.archiva_admin=Archiva System Administrator
>
> However, this does not grant members of the archiva_admin group the
> Archiva System Administrator role. Additionally, I added the following
> snippet (on a whim) to the archiva.xml file:
> <role>
> <archiva_admin>Archiva System Administrator</archiva_admin>
> </role>
>
> That is added inside the:
> <ldap>
> <config>
> <groups>
> section. It does make a property show up in the Properties tab of the
> "Users Runtime Configuration" but it has no effect.
>
> The mapping I would like to setup will be permanent, so it does not
> need to work properly in the UI. I don't mind adding the configuration
> manually into a config file on the server. However, I can't seem to
> find any way to make the mapping work.
>
> -Wes
>
> --
> Wes Wannemacher



-- 
Wes Wannemacher

Mime
View raw message