archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olivier Lamy <ol...@apache.org>
Subject Re: MRM-1791 doesn't seem to be fixed
Date Tue, 04 Mar 2014 11:59:56 GMT
On 4 March 2014 20:22, Sascha Vogt <sascha.vogt@gmail.com> wrote:
> Hi Chris,
>
> Am 04.03.2014 01:00, schrieb Harris, Christopher P:
>> The LDAP config is correct.  The tests conducted by the "Verify LDAP
>> changes." and "Verify LDAP configuration on server side." Buttons
>> successfully execute.
> Well, those tests don't really verify much ;)

yup only we can connect to the ldap server with the credentials (not more :-) )

>
>> However, when I navigate to the "LDAP/Roles Mapping" tab, no groups
>> are listed within the LDAP Groups dropdown menu.
> You need to tweak a few things before that'll work
>
>> This has never worked for me.  How do I get this to work?
> First, check that under "Users Runtime Configuration" you have added the
> LDAP RBac Manager. We have both, database first, LDAP second for both,
> UserManager and RbacManager.
>
> Second, tab LDAP:
> baseDn, for the users to login
> base Dn for groups, your groups are here
>
> Third, Properties tab:
> ldap.config.mapper.attribute.user.id = sAMAccountName
> ldap.config.mapper.attribute.password = userPassword
> ldap.config.mapper.attribute.user.object.class = user
>
> 4th, archiva.xml
> /configuration/redbackRuntimeConfiguration/configurationProperties/ldap
> (XML path)
>
> Make sure you have
> <config>
>     <groups>
>         <member>member</member>
>         <class>group</class>
>     </groups>
> ...
> </config>
> in there.

can be added in the properties tab (normally :-) )

>
> Then you should be able to see in LDAP/Roles Mapping a dropdown filled
> with your groups.
>
> Hope that helps,
> Greetings
> -Sascha-



-- 
Olivier Lamy
Ecetera: http://ecetera.com.au
http://twitter.com/olamy | http://linkedin.com/in/olamy

Mime
View raw message