archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stallard,David" <stall...@oclc.org>
Subject RE: Archiva 1.3.5 database administration question
Date Tue, 12 Nov 2013 14:23:59 GMT
Brett, to be clear what you mean by deleting the indexes, would that mean deleting both the
.index and .indexer directories under each of our repositories?  Will Archiva be available
for use while those are being recreated?  We fixed an issue a few months ago by deleting the
database and I don't recall that affecting availability, not sure if the index is different.

Thanks,
David

-----Original Message-----
From: Brett Porter [mailto:brett@porterclan.net] On Behalf Of Brett Porter
Sent: Monday, November 11, 2013 7:12 PM
To: users@archiva.apache.org
Subject: Re: Archiva 1.3.5 database administration question

Hi David,

On 12 Nov 2013, at 7:29 am, Stallard,David <stallard@oclc.org> wrote:

> According to the following page, there should be 6 configurable Unprocessed Artifacts
Consumers and 3 Artifact Cleanup Consumers:
> 
> http://archiva.apache.org/docs/1.3.5/adminguide/consumers.html
> 

It looks like that documentation is out of date. There is only the one database consumer now
(and this further changes in the upcoming Archiva 2.0 release).

> We have had various error messages in the log and unreliable searching for a long time
now, and I suspect it may be because database consumers such as index-archive-toc, index-artifact,
and so forth, are not running.

We can probably help with those errors individually, although if you are looking for a clean
attempt you can move the Archiva database and indexes out of the way and restart it - that
should certainly correct the issues if you can afford the time and CPU cycles to reindex.

Regards,
Brett

--
Brett Porter   @brettporter
http://brettporter.wordpress.com/
http://au.linkedin.com/in/brettporter




Mime
View raw message