archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Deng Ching <och...@apache.org>
Subject Re: Cannot download SNAPSHOT from Archiva when listed as dependency
Date Wed, 19 Sep 2012 03:38:54 GMT
Hi Chris,

You need to add the snapshots repo as follows:

<profile>
      <id>snapshots-profile</id>
      <activation>
        <activeByDefault>true</activeByDefault>
      </activation>
      <repositories>
        <repository>
          <id>snapshots.repo</id>
          <name>Your Snapshots Repo</name>
          <url>https://archiva.repo/archiva/repository/snapshots</url>
          <releases>
            <enabled>false</enabled>
          </releases>
          <snapshots>
            <enabled>true</enabled>
          </snapshots>
         </repository>
       </repositories>
</profile>

Then change <mirrorOf> to:

<mirrorOf>external:*,!snapshots.repo</mirrorOf>

 HTH,
Deng

On Wed, Sep 19, 2012 at 7:23 AM, Harris, Christopher P <
chris_harris@baxter.com> wrote:

> Hi,
>
> I've done several hours worth of searching and experimenting for a
> resolution to this problem with no luck:
> I've created an managed repo to house in-house snapshots along with some
> special 3rd-party snapshots.  I cannot download 2 3rd-party snapshots.
>
> I get these 2 error messages:
> The POM for org.apache.myfaces.tomahawk:tomahawk12:jar:1.1.14-SNAPSHOT is
> missing, no dependency information available
> The POM for
> org.apache.myfaces.tomahawk:tomahawk-sandbox12:jar:1.1.14-SNAPSHOT is
> missing, no dependency information available
>
> My settings.xml:
>
> <mirror>
>       <id>some_id</id>
>       <url>http://localhost:8083/archiva/repository/repo_group_name/</url>
>       <mirrorOf>*</mirrorOf>
> </mirror>
>
> I've tried adding an active-by-default profile to my snapshots repo, but
> that didn't work.
>
> To upload the .jar & .pom files, I've copied them from my local Maven repo
> to my C:\ and then uploaded the snapshots via command prompt:
>
> C:\>mvn deploy:deploy-file -Dfile=tomahawk12-1.1.14-SNAPSHOT.jar
> -DpomFile=tomah
> awk12-1.1.14-SNAPSHOT.pom -DrepositoryId=repo-snapshots -Durl=
> http://localhos
> t:8083/archiva/repository/repo-snapshots/ -DuniqueVersion=false
> -DupdateRelea
> seInfo=true
>
> Note that deploy:deploy-file only works using artifacts not in my local
> Maven repo.  That's why I move them to C:\
>
> I originally tried uploading without uniqueVersion and updateReleaseInfo.
>  No luck either.
>
> I opened up a simple tester project in NetBeans and added these 2
> dependencies.  Sure enough, when I type in <version></version> and hit Ctrl
> + the space bar, I see 1.1.14-SNAPSHOT listed as a hint.  I can also access
> the pom and jar in Archiva from my browser.
>
> How can I download snapshot dependencies from Archiva?
>
>
> -    Chris Harris
>
> The information transmitted is intended only for the person(s)or entity to
> which it is addressed and may contain confidential and/or legally
> privileged material. Delivery of this message to any person other than the
> intended recipient(s) is not intended in any way to waive privilege or
> confidentiality. Any review, retransmission, dissemination or other use of
> , or taking of any action in reliance upon, this information by entities
> other than the intended recipient is prohibited. If you receive this in
> error, please contact the sender and delete the material from any computer.
>
> For Translation:
>
> http://www.baxter.com/email_disclaimer
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message