archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Barboni" <>
Subject RE: LDAP Issues
Date Fri, 14 Sep 2012 08:40:36 GMT
Hi, sorry I never tried archiva and ldap 

Maybe this is related to
There are some old but different information here also


-----Message d'origine-----
De : Harris, Christopher P [] 
Envoyé : vendredi 14 septembre 2012 00:09
À :
Objet : LDAP Issues


I've set up archiva-webapp-js-1.4-M3-SNAPSHOT.war to utilize  I followed  Yes, I know it's
out of date.  So, I went and downloaded the stand-alone version of Archiva
v1.4-M3.  I found applicationContext.xml and noticed the commented-out beans
and instructions left for modifying

I enabled the beans and modified accordingly:





Initially, I couldn't even start Archiva once I enabled LDAP.  Through trial
and error using Apache Directory Studio, I was able to successfully
configure LDAP.  Now, Archiva can start again since it can communicate via
LDAP to our AD server.

There are some problems though:

1.)    The initial user Archiva/Redback tries to log in as (myself) but
cannot be found.  I see the logs return a variable "foundUser" with a value
of false.  I know I have the right dn.

2.)    Archiva cannot find any users via LDAP subtree searching.  I'm not
sure if I have to create the user in Archiva first (I assume that I do).

3.)    Thinking that I need to create an Archiva user for myself so that
problems #1 and #2 can be resolved, I tried to log in as admin.  The only
problem is that Archiva would not let me log in as admin any more.  I see in
archiva.log that LDAP is querying AD for admin.  Of course, admin cannot be
found.  I thought "redback.default.admin=admin" would allow me to log in as
admin as I did before I enabled LDAP.

Note that my Active Directory account is not an admin account.  I can't see
any AD values named "userPassword".  I may need to be admin to even see that
field.  I figured that it would be visible but contain encrypted values.
ldap.config.mapper.attribute.password=userPassword is what I'm basing this
on.  I plan on implementing an admin account, but haven't been given that
information yet.

Any suggestions?

-    Chris Harris
The information transmitted is intended only for the person(s)or entity to
which it is addressed and may contain confidential and/or legally privileged
material. Delivery of this message to any person other than the intended
recipient(s) is not intended in any way to waive privilege or
confidentiality. Any review, retransmission, dissemination or other use of ,
or taking of any action in reliance upon, this information by entities other
than the intended recipient is prohibited. If you receive this in error,
please contact the sender and delete the material from any computer.

For Translation:

View raw message