archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Harris, Christopher P" <chris_har...@baxter.com>
Subject RE: Cannot get Archiva to create tables in 'archiva' database in MySQL 5.5
Date Thu, 30 Aug 2012 15:08:24 GMT
Thanks, Eric.

 - Chris


-----Original Message-----
From: Eric Barboni [mailto:Eric.Barboni@irit.fr] 
Sent: Wednesday, August 29, 2012 2:10 PM
To: users@archiva.apache.org
Subject: Re: Cannot get Archiva to create tables in 'archiva' database in MySQL 5.5

 
Hi Chris

AFAIK 1.4-M1 drop "archiva" database see http://jira.codehaus.org/browse/MRM-1025 in favor
of more reliable API and workflow.
So IMHO you are doing nothing wrong.

Regards

Eric


Le Mercredi 29 Août 2012 19:36 CEST, "Harris, Christopher P" <chris_harris@baxter.com>
a écrit: 
 
> Hi.
> 
> I've set up Archiva apache-archiva-1.4-M2.war on Windows XP using Tomcat 7.0.26 (base
separated from installation).
> 
> I've set up a MySQL 5.5 database.  The problem is that I see no tables or data getting
populated in just the archiva schema for the "archiva" user.  However, I am seeing tables
and data populating the users schema for the "users" user.
> 
> I used this script:
> create database archiva;
> 
> create database users;
> 
> use mysql;
> GRANT SELECT,INSERT,UPDATE,DELETE,CREATE,DROP,ALTER,INDEX ON archiva.* TO 'archiva'@'localhost'
IDENTIFIED BY 'archiva';
> GRANT SELECT,INSERT,UPDATE,DELETE,CREATE,DROP,ALTER,INDEX ON users.* TO 'users'@'localhost'
IDENTIFIED BY 'users';
> 
> I can successfully launch the Archiva .war in Tomcat.  Upon my initial launch of Archiva,
I was prompted to create the admin.  Once I created the admin, the admin showed up in the
jdouser table in the users schema.  The guest user is present as well.
> 
> I've attached archiva.log.
> 
> I see that the \path\to\tomcat_base_archiva\data\repositories\*  directories default
internal and snapshots repositories are getting created within my file system.  That would
indicate that Derby is getting used for the repositories, correct?
> 
> Here's my archiva.xml from \path\to\tomcat_base_archiva\conf\Catalina\localhost
> <Context path="/archiva"
>          docBase="C:/apache/tomcat_base_archiva/archiva/apache-archiva-1.4-M2.war"
>          reloadable="true"
>          antiJARLocking="true"
>          antiResourceLocking="true">
> 
>          <!-- docBase="${catalina.home}/archiva/apache-archiva-1.4-M2.war"> -->
>   <Resource name="jdbc/users"
>             auth="Container"
>             type="javax.sql.DataSource"
>             username="users"
>             password="users"
>             driverClassName="com.mysql.jdbc.Driver"
>             url="jdbc:mysql://localhost:3306/users?autoReconnect=true"/>
> 
>   <Resource name="jdbc/archiva"
>             auth="Container"
>             type="javax.sql.DataSource"
>             username="archiva"
>             password="archiva"
>             driverClassName="com.mysql.jdbc.Driver"
>             url="jdbc:mysql://localhost:3306/archiva?autoReconnect=true"/>
> 
>   <Resource name="mail/Session"
>             auth="Container"
>             type="javax.mail.Session"
>             mail.smtp.host="localhost"/>
> </Context>
> 
> I poked around in the Archiva code on SVN here :
> http://svn.apache.org/viewvc/archiva/tags/archiva-1.4-M2/archiva-modules/archiva-web/archiva-webapp/src/
> I looked at the jetty config file jetty-env-mysql.xml and noticed that the archiva user
is given the password 'sa'.
> I noticed that here too:
> http://svn.apache.org/viewvc/archiva/tags/archiva-1.4-M2/archiva-modules/archiva-web/archiva-webapp/src/sql/mysql/drop_archiva_tables.sql?view=markup
> So, I even tried changing the "archiva" user's password to sa within MySQL and in archiva.xml.
> 
> That didn't work.
> 
> I've read about a  bug where MySQL db's shouldn't be set to UTF-8, but that bug appears
to have affected older Archiva versions.  Both my users and archiva tables are set to UTF-8.
> 
> It's odd that the users db is being utilized, but the archiva db is not.
> 
> What am I doing wrong?
> 
> I'm tempted to try PostgreSQL, but I don't want to open another potential can of worms
just yet.
> 
> 
> -    Chris
> The information transmitted is intended only for the person(s)or entity to which it is
addressed and may contain confidential and/or legally privileged material. Delivery of this
message to any person other than the intended recipient(s) is not intended in any way to waive
privilege or confidentiality. Any review, retransmission, dissemination or other use of ,
or taking of any action in reliance upon, this information by entities other than the intended
recipient is prohibited. If you receive this in error, please contact the sender and delete
the material from any computer.
> 
> For Translation:
> 
> http://www.baxter.com/email_disclaimer
 
 
 
 
The information transmitted is intended only for the person(s)or entity to which it is addressed
and may contain confidential and/or legally privileged material. Delivery of this message
to any person other than the intended recipient(s) is not intended in any way to waive privilege
or confidentiality. Any review, retransmission, dissemination or other use of , or taking
of any action in reliance upon, this information by entities other than the intended recipient
is prohibited. If you receive this in error, please contact the sender and delete the material
from any computer.

For Translation:

http://www.baxter.com/email_disclaimer
Mime
View raw message