archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff <predato...@gmail.com>
Subject Re: Archiva indexes for multiple repo groups/3rd party proxies...
Date Mon, 30 Jul 2012 20:48:38 GMT
I've been fiddling and noticed that when it tries to connect to the Maven
Central index location at
http://repo1.maven.org/maven2/.index/nexus-maven-repository-index.propertiesI
see:

2012-07-30 14:44:20,825 [taskScheduler#indexDownloadRemote-4] INFO
 org.apache.archiva.scheduler.indexing.DownloadRemoteIndexTask$DownloadListener
 - error of transfer file [nexus-maven-repository-index.properties, Access
denied to:
http://repo1.maven.org/maven2/.index/nexus-maven-repository-index.properties,
ReasonPhrase:Forbidden.]:
org.apache.maven.wagon.authorization.AuthorizationException: Access denied
to:
http://repo1.maven.org/maven2/.index/nexus-maven-repository-index.properties,
ReasonPhrase:Forbidden.


However, when I go to that URL directly or do a wget from the Archiva
server, it downloads just fine.

Any idea why?

On Mon, Jul 30, 2012 at 11:17 AM, Olivier Lamy <olamy@apache.org> wrote:

> 2012/7/26 Jeff <predatorvi@gmail.com>:
> > In my NetBeans environment, it pulls the Maven indexes and gives me hints
> > when I <CTRL>-<SPACE> on versions or artifact ID's, etc.
> >
> > However, it seems that the indexes that NetBeans pulls from my Archiva
> > server is not handling all of the indexes for all of my repositories like
> > it used to and I don't know what I've done wrong.
> >
> > I have 6 managed repositories:
> >
> >    - 3rd-party-releases
> >    - 3rd-party-snapshots
> >    - team1-releases
> >    - team1-snapshots
> >    - team2-releases
> >    - team2-snapshots
> >
> > I also have 16 remote repositories.  Some of them are "release"
> > repositories (central, java.net, etc.) that are connected via proxy to
> the
> > "3rd-party-releases" managed repo.  Some are remote snapshot repos that
> are
> > proxied to the "3rd-party-snapshots" managed repo.
> >
> > I then have one repository group that contains all 6 managed repos.
> >
> > I have defined explicit index directories for each managed repository as
> > well as the remote repos.
> >
> > For all remote repositories, I have checked "Activate download remote
> > index", attempted to specify the "Remote index url" (for Central it is
> set
> > to .index), but some don't seem to generate indexes.
> Are you sure remote repositories generate an index file ?
>
> BTW with 1.4-M2 there is now an aggregated indice file in your group.
>
> >
> > However, it seems to not contain all of the versions of the artifacts.
> >
> > Did I set up my repo wrong or is it something else?  I don't know where
> to
> > look?
> >
> > Thanks!
> >
> > --
> > Jeff Vincent
> > predatorvi@gmail.com
> > See my LinkedIn profile at:
> > http://www.linkedin.com/in/rjeffreyvincent
> > I ♥ DropBox <http://db.tt/9O6LfBX> !!
>
>
>
> --
> Olivier Lamy
> Talend: http://coders.talend.com
> http://twitter.com/olamy | http://linkedin.com/in/olamy
>



-- 
Jeff Vincent
predatorvi@gmail.com
See my LinkedIn profile at:
http://www.linkedin.com/in/rjeffreyvincent
I ♥ DropBox <http://db.tt/9O6LfBX> !!

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message