archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <>
Subject Re: Repository indexing not working
Date Tue, 15 Nov 2011 18:51:02 GMT

On 15/11/2011, at 10:31 AM, madhu phatak wrote:

> Thanks for quick replies :)
> On Tue, Nov 15, 2011 at 11:47 PM, Brett Porter <> wrote:
>> I'd recommend upgrading to 1.3.5, even though it may not impact this
>> particular problem.
>> Either way, the DB is the one that is missing information. The best course
>> is to go to the repositories page, check "Process All Artifacts" and press
>> "Scan Repository Now". This will force everything to be scanned.
>   I tried this but nothing changed
> If things are still missing, there are other possibilities:
>> - the artefacts you want scanned are not included in the artefacts list on
>> the repository scanning configuration page
>      U mean the patterns?

Yes, that's right.

>> - old versions of the snapshots are actually being purged (I didn't think
>> that's what you meant, but it's worth noting)
>     If they are purged corresponding jar or pom should not be there
> in file system right? I can see the jars in filesystem but when i browse
> repo through browser it doesn't show many artifacts


>> You can look in the logs for more details on what eventually gets scanned
>> as well.
> I try to see in archiva.log but it doesnot give much info on whats
> going.Should i see somewhere else?

There is a summary at the end with a number of files - I'd hoped that would give you a comparison.
There should also be any warnings or errors that occur during the scan.

If that's not helping, try increasing the logging level to debug in the log4j.xml and scan
again. That should give lots of information on individual files.

Another option is to stop, delete the archiva database, and start again - that would clear
any bad state. Not sure if you tried that already.

- Brett

Brett Porter

View raw message