archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Szelag, Lukasz" <lukasz.sze...@baml.com>
Subject Errors deploying to repository using WebDAV (Archiva 1.3.5)
Date Tue, 25 Oct 2011 21:33:10 GMT
Maven deployment of an artifact fails using WebDAV.

Maven log:

-------
[INFO] [deploy:deploy {execution: default-deploy}]
WAGON_VERSION: 1.0-beta-2
Uploading: http://<server-name>:8080/archiva/repository/<repo-name>/<artifact-path>
Oct 25, 2011 5:19:04 PM org.apache.commons.httpclient.HttpMethodBase processRedirectResponse
INFO: Redirect requested but followRedirects is disabled
Oct 25, 2011 5:19:04 PM org.apache.commons.httpclient.HttpMethodBase processAuthenticationResponse
INFO: Already tried to authenticate with 'Repository Archiva Managed  Repository' authentication
realm at <server-name>, but still receiving: HTTP/1.1 401 Unauthorized
Oct 25, 2011 5:19:04 PM org.apache.commons.httpclient.HttpMethodBase processAuthenticationResponse
INFO: Already tried to authenticate with 'Repository Archiva Managed <repo-name> Repository'
authentication realm at <server-name>, but still receiving: HTTP/1.1 401 Unauthorized
-------

Tomcat access log:

-------
<IP address> - - [25/Oct/2011:17:19:04 -0400] "PUT /archiva/repository/<repo-name>/<artifact-path>
HTTP/1.1" 401 990
-------

I followed instructions posted at http://archiva.apache.org/docs/1.0/userguide/deploy.html.

The repository can be viewed at this URL:

http://<server-name>:8080/archiva/repository/<repo-name>/<artifact-path>

Checklist:

- defined a user in Archiva and granted it Global Repository Manager role
- the user is listed in servers section in settings.xml
- the target repository is listed in settings.xml referencing the server ID above
- the project's pom.xml lists the target repository under distribution management
- wagon-webdav (1.0-beta-2) is specified in pom.xml as a build extension
- wagon-webdev JAR is present under MAVEN_HOME/lib directory

I don't know what else could go wrong... I also tried wagon-webdav-jackrabbit (2.0) without
any success.

Any help would be appreciated.

Thanks,
Lukasz

----------------------------------------------------------------------
This message w/attachments (message) is intended solely for the use of the intended recipient(s)
and may contain information that is privileged, confidential or proprietary. If you are not
an intended recipient, please notify the sender, and then please delete and destroy all copies
and attachments, and be advised that any review or dissemination of, or the taking of any
action in reliance on, the information contained in or attached to this message is prohibited.

Unless specifically indicated, this message is not an offer to sell or a solicitation of any
investment products or other financial product or service, an official confirmation of any
transaction, or an official statement of Sender. Subject to applicable law, Sender may intercept,
monitor, review and retain e-communications (EC) traveling through its networks/systems and
may produce any such EC to regulators, law enforcement, in litigation and as required by law.

The laws of the country of each sender/recipient may impact the handling of EC, and EC may
be archived, supervised and produced in countries other than the country in which you are
located. This message cannot be guaranteed to be secure or free of errors or viruses. 

References to "Sender" are references to any subsidiary of Bank of America Corporation. Securities
and Insurance Products: * Are Not FDIC Insured * Are Not Bank Guaranteed * May Lose Value
* Are Not a Bank Deposit * Are Not a Condition to Any Banking Service or Activity * Are Not
Insured by Any Federal Government Agency. Attachments that are part of this EC may have additional
important disclosures and disclaimers, which you should read. This message is subject to terms
available at the following link: 
http://www.bankofamerica.com/emaildisclaimer. By messaging with Sender you consent to the
foregoing.

Mime
View raw message