archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff <predato...@gmail.com>
Subject Re: New to archiva and it's kicking my butt...
Date Thu, 01 Sep 2011 21:53:02 GMT
Okay, I found my problem.

After writing a lengthy e-mail detailing my exact steps, culminating with a
running Tomcat+Archiva+Derby with no errors, but still not being able to
connect (request to archiva url just sits and spins), I undeployed SONAR and
it worked! :)

I've now split SONAR and Archiva into their own Tomcat instances ... yay!
Not sure why they didn't like to work together.

I was also able to connect to our MySQL database server as well (once I
included the right JDBC connector JAR).

Thanks for the nudge in the right direction.

On Thu, Sep 1, 2011 at 12:27 AM, Brett Porter <brett@apache.org> wrote:

> We can certainly help with configs for MySQL or Postgres on Tomcat or Jetty
> too…
>
> There are some examples here:
> https://cwiki.apache.org/confluence/display/ARCHIVA/Archiva+with+MySQL
> https://cwiki.apache.org/confluence/display/ARCHIVA/Archiva+on+Tomcat
>
> - Brett
>
> On 01/09/2011, at 1:06 PM, Jeff wrote:
>
> > Thank you!!  I didn't think 64-bit would be an issue, but didn't consider
> > the JSW native binaries might have an issue.
> >
> > As for Tomcat, I have Tomcat6 installed and tried the WAR install, but
> had
> > other issues when trying to connect to MySQL.  Maybe I should try tomcat
> > with default Jetty...
> >
> > On Wed, Aug 31, 2011 at 6:31 PM, Brett Porter <brett@apache.org> wrote:
> >
> >> This particular PATH and JAVA_HOME setup worked on my 32-bit Windows 7
> >> machine.
> >>
> >> There is this:
> >>
> http://old.nabble.com/Critical-error%3A-wait-for-JVM-process-failed-td18087924.html-says
reinstallation of Java helped.
> >>
> >> Another guess is that x64 is a problem, because the Java Service Wrapper
> we
> >> use only has a commercial license for the 64-bit windows wrapper. As far
> as
> >> I'm aware, the 32-bit one works on there though.
> >>
> >> If these continue to be a problem, you might consider installing Jetty
> or
> >> Tomcat (or another app server you are familiar with) and deploy the
> Archiva
> >> WAR into it - you can find instructions for that on the web site.
> >>
> >> Hope that helps!
> >>
> >> Cheers,
> >> Brett
> >>
> >> On 01/09/2011, at 6:21 AM, Jeff wrote:
> >>
> >>> Running on Windows Server 2008 R2 sp1 x64.
> >>>
> >>> I'm sure the issue will turn out to be a n00b mistake, but ...
> >>>
> >>> I am trying to just run the standalone and get it working.  I'll try it
> >> as a
> >>> WAR later.  My settings are:
> >>>
> >>> Archiva files at:  C:\WebApps\archiva-1.3.5
> >>> JAVA_HOME=C:\Program Files\Java\jre6
> >>>
> >>
> PATH=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;
> >>> *C:\WebApps\archiva-1.3.5\bin\*
> >>>
> >>> C:\WebApps\archiva-1.3.5>java -version
> >>>
> >>> java version "1.6.0_27"
> >>> Java(TM) SE Runtime Environment (build 1.6.0_27-b07)
> >>> Java HotSpot(TM) 64-Bit Server VM (build 20.2-b06, mixed mode)
> >>>
> >>>
> >>> Steps (with output):
> >>>
> >>> C:\WebApps\archiva-1.3.5>*java -version*
> >>> *java version "1.6.0_27"
> >>> Java(TM) SE Runtime Environment (build 1.6.0_27-b07)
> >>> Java HotSpot(TM) 64-Bit Server VM (build 20.2-b06, mixed mode)*
> >>> C:\WebApps\archiva-1.3.5>*path*
> >>> *
> >>>
> >>
> PATH=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\WebApps\archiva-1.3.5\bin\
> >>> *
> >>> C:\WebApps\archiva-1.3.5>*bin\archiva.bat install
> >>> **wrapper  | Apache Archiva installed.*
> >>> C:\WebApps\archiva-1.3.5>*bin\archiva.bat start
> >>> **wrapper  | Starting the Apache Archiva service...
> >>> wrapper  | The Apache Archiva service was launched, but failed to
> start.
> >>> Press any key to continue . . .*
> >>>
> >>>
> >>> wrapperXXX.log content:
> >>>
> >>> STATUS | wrapper  | 2011/08/31 14:09:31 | Starting the Apache Archiva
> >>> service...
> >>> STATUS | wrapper  | 2011/08/31 14:09:31 | --> Wrapper Started as
> Service
> >>> STATUS | wrapper  | 2011/08/31 14:09:31 | Launching a JVM...
> >>> FATAL  | wrapper  | 2011/08/31 14:09:31 | *Unable to execute Java
> >> command.
> >>> The system cannot find the file specified. (0x2)*
> >>> FATAL  | wrapper  | 2011/08/31 14:09:31 |     "java" -Dappserver.home=.
> >>> -Dappserver.base=. -Djetty.logs=./logs -Djava.library.path="lib"
> >> -classpath
> >>>
> >>
> "lib/wrapper.jar;lib/archiva-jetty-1.3.5.pom;lib/jetty-6.1.19.jar;lib/jetty-util-6.1.19.jar;lib/servlet-api-2.5-20081211.jar;lib/start-6.1.19.jar;lib/jetty-naming-6.1.19.jar;lib/jsp-2.1-jetty-6.1.19.jar;lib/core-3.1.1.jar;lib/jsp-api-2.1-glassfish-9.1.1.B60.25.p0.jar;lib/jsp-2.1-glassfish-9.1.1.B60.25.p0.jar;lib/jetty-plus-6.1.19.jar;lib/geronimo-spec-jta-1.0.1B-rc4.jar;lib/derby-10.1.3.1.jar;lib/mail-1.4.jar;lib/activation-1.1.jar;lib/ant-1.6.5.jar;lib/commons-dbcp-1.2.1.jar;lib/commons-collections-3.2.jar;lib/commons-pool-1.2.jar;lib/xml-apis-1.0.b2.jar;lib/xercesImpl-2.8.1.jar"
> >>> -Dwrapper.key="TFFp8XlxVgaOBniO" -Dwrapper.port=32000
> >>> -Dwrapper.jvm.port.min=31000 -Dwrapper.jvm.port.max=31999
> >> -Dwrapper.pid=3132
> >>> -Dwrapper.version="3.2.3" -Dwrapper.native_library="wrapper"
> >>> -Dwrapper.service="TRUE" -Dwrapper.cpu.timeout="10" -Dwrapper.jvmid=1
> >>> org.tanukisoftware.wrapper.WrapperSimpleApp org.mortbay.start.Main
> >>> ./conf/jetty.xml
> >>> FATAL  | wrapper  | 2011/08/31 14:09:31 | Critical error: wait for JVM
> >>> process failed
> >>> ERROR  | wrapper  | 2011/08/31 14:09:33 | The Apache Archiva service
> was
> >>> launched, but failed to start.
> >>>
> >>> I'm not sure what file it can't find.  It can find java.exe as well as
> >> the
> >>> wrapperXXX.exe.  If there is something else I need to tweak, I'm unable
> >> to
> >>> find it in the docs.
> >>>
> >>> I get the same result starting with the 'console' parameter'.
> >>>
> >>> Thanks in advance for any help!
> >>>
> >>> --
> >>>
> >>> Jeff Vincent
> >>> predatorvi@gmail.com
> >>> See my LinkedIn profile at:
> >>> http://www.linkedin.com/in/rjeffreyvincent
> >>> I ♥ DropBox <http://db.tt/9O6LfBX> !!
> >>
> >> --
> >> Brett Porter
> >> brett@apache.org
> >> http://brettporter.wordpress.com/
> >> http://au.linkedin.com/in/brettporter
> >>
> >>
> >>
> >>
> >>
> >
> >
> > --
> > Jeff Vincent
> > predatorvi@gmail.com
> > See my LinkedIn profile at:
> > http://www.linkedin.com/in/rjeffreyvincent
> > I ♥ DropBox <http://db.tt/9O6LfBX> !!
>
> --
> Brett Porter
> brett@apache.org
> http://brettporter.wordpress.com/
> http://au.linkedin.com/in/brettporter
>
>
>
>
>


-- 
Jeff Vincent
predatorvi@gmail.com
See my LinkedIn profile at:
http://www.linkedin.com/in/rjeffreyvincent
I ♥ DropBox <http://db.tt/9O6LfBX> !!

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message