archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: WELCOME to users@archiva.apache.org
Date Mon, 20 Jun 2011 05:53:09 GMT
The simplest is to remove the <uniqueVersion>false</uniqueVersion> when you deploy
so that the snapshots are deployed with a timestamp & build number.

On 20/06/2011, at 2:57 PM, Martin Schwarzbauer wrote:

> Hello Brett,
> 
> i am using the snapshot deploy repo for out deployment snapshot (still
> testing). I wanna deploy the snapshot and fetch these artifacts
> (XXX--0.1-SNAPSHOT.jar) as a dependency in another maven project. The
> problem is, that i can't fetch the SNAPSHOT version as a dependency from the
> repo! Why?
> 
> How to handle this?
> 
> Thx,
> Martin
> 
> 2011/6/20 Brett Porter <brett@apache.org>
> 
>> Sorry, I'm a bit unclear what you are trying to do here with the snapshot.
>> Is it your objective to use a timestamp (in which case, you need to change
>> the snapshotRepository in your distributionManagement), or to not use a
>> timestamp (in which case, Maven 3 will not be able to deploy or retrieve the
>> artifact)?
>> 
>> I recommend using timestamps, and turning on Archiva's "purge snapshots"
>> feature to better maintain disk space.
>> 
>> - Brett
>> 
>> On 17/06/2011, at 7:44 PM, Martin Schwarzbauer wrote:
>> 
>>> Hello the problem is still not fixed! Here again my setup:
>>> 
>>> * maven 3.0.3
>>> * Archiva 1.3.3
>>> 
>>> * Internal Proxy repo with further remote repos.
>>> * deploy and deploy_snapshot repo
>>> * these three repos are in ONE repository group (spr_internal)
>>> 
>>> My settings.xml:
>>> <mirror>
>>>     <id>internal</id>
>>>     <mirrorOf>*</mirrorOf>
>>>     <name>Internal Sprecher Automation Repository.</name>
>>>     <url>
>>> http://febuild1.sprecher-automation.com/archiva/repository/spr_internal/
>>> </url>
>>>   </mirror>
>>> 
>>> In pom.xml:
>>> 
>>> <distributionManagement>
>>> <repository>
>>> <id>deploy</id>
>>> <name>Internal Release Repository</name>
>>> <url>http://10.1.2.140/archiva/repository/deploy/</url>
>>> </repository>
>>> <snapshotRepository>
>>>   <uniqueVersion>false</uniqueVersion>
>>> <id>deploy_snapshot</id>
>>> <name>Internal Snapshot Repository</name>
>>> <url>http://10.1.2.140/archiva/repository/deploy_snapshot</url>
>>> </snapshotRepository>
>>> </distributionManagement>
>>> 
>>> I can deploy this artifact (SNAPSHOT) into deploy_snapshot. In another
>>> project i use this SNAPSHOT-Version as dependency but maven can't fetch
>> it
>>> from archiva repo. I think there is a problem with the timestamp in the
>>> SNAPSHOT repo? The tag <uniqueVersion>false</uniqueVersion>
>>> doesn't work in Maven3!
>>> 
>>> Can anybody help me?
>>> 
>>> thx,
>>> Martin
>>> 
>>> 
>>> 2011/6/14 Mohni, Daniel <daniel.mohni@ch.unisys.com>
>>> 
>>>> Hi Martin
>>>> 
>>>> Questions 1: Is this url available in a web browser ?
>>>> 
>>>> 
>>>> 
>> http://febuild1/archiva/repository/internal/at/sprecher/web/rest/service/WebService/1.0-SNAPSHOT/WebService-1.0-SNAPSHOT.pom
>>>> 
>>>> Question 2: Did you add the snapshot repository to the 'internal'
>>>> repository group ?
>>>> 
>>>> Cheers
>>>> Daniel
>>>> 
>>>> -----Urspr√ľngliche Nachricht-----
>>>> Von: Martin Schwarzbauer [mailto:martin.schwarzbauer@gmail.com]
>>>> Gesendet: Dienstag, 14. Juni 2011 09:55
>>>> An: users@archiva.apache.org
>>>> Betreff: Re: WELCOME to users@archiva.apache.org
>>>> 
>>>> Hi *!
>>>> 
>>>> I have got a problem using Archiva! The story is:
>>>> 
>>>> I am using ARCHIVA to proxy all the remote repos.
>>>> 
>>>> My Configuration is:
>>>> Internal repository -> proxies different remote repos.
>>>> In my settings.xml i have:
>>>> <mirror>
>>>>    <id>internal</id>
>>>>    <mirrorOf>*</mirrorOf>
>>>>    <name>Internal Sprecher Automation Repository.</name>
>>>>    <url>http://febuild1/archiva/repository/internal/</url>
>>>>  </mirror>
>>>> 
>>>> so that all of me request will be handled by the proxy!
>>>> 
>>>> I also created TWO repositories for deployment -> deploy and
>>>> deploy.snapshot.
>>>> 
>>>> In my POM.xml i have:
>>>> <distributionManagement>
>>>> <repository>
>>>> <id>archiva.deploy</id>
>>>> <name>Internal Release Repository</name>
>>>> <url>http://10.1.2.140/archiva/repository/deploy/</url>
>>>> </repository>
>>>> <snapshotRepository>
>>>> <id>archiva.deploy.snapshots</id>
>>>> <name>Internal Snapshot Repository</name>
>>>> <url>http://10.1.2.140/archiva/repository/deploy.snapshots</url>
>>>> </snapshotRepository>
>>>> </distributionManagement>
>>>> 
>>>> The different artifacts (*.jars, *.zip) get deployed correctly (either
>>>> SNAPSHOT or not) !
>>>> 
>>>> My Problem:
>>>> I will use the deployed JAR as a dependency in another project -> BUT
>> this
>>>> doesn't work for SNAPSHOTS!
>>>> 
>>>> I always get:
>>>> [...]
>>>> Downloading:
>>>> 
>>>> 
>> http://febuild1/archiva/repository/internal/at/sprecher/web/rest/service/WebService/1.0-SNAPSHOT/maven-metadata.xml
>>>> Downloading:
>>>> 
>>>> 
>> http://febuild1/archiva/repository/internal/at/sprecher/web/rest/service/WebService/1.0-SNAPSHOT/maven-metadata.xml
>>>> Downloading:
>>>> 
>>>> 
>> http://febuild1/archiva/repository/internal/at/sprecher/web/rest/service/WebService/1.0-SNAPSHOT/WebService-1.0-SNAPSHOT.pom
>>>> [WARNING] The POM for
>>>> at.sprecher.web.rest.service:WebService:jar:1.0-SNAPSHOT is missing, no
>>>> dependency information available
>>>> [...]
>>>> [ERROR] Failed to execute goal on project SWTConfigTool: Could not
>> resolve
>>>> dependencies for project
>>>> at.sprecher.web.swt.configtool:SWTConfigTool:jar:0.0.1-SNAPSHOT: The
>>>> following artifacts could not be resolved:
>>>> at.sprecher.web.rest.service:WebService:jar:1.0-SNAPSHOT,
>>>> at.sprecher.web.gwt.config:GWTConfigTool:war:0.0.1-SNAPSHOT,
>>>> at.sprecher.web.gwt.base:WebBase:jar:1.0-SNAPSHOT: Could not find
>> artifact
>>>> at.sprecher.web.rest.service:WebService:jar:1.0-SNAPSHOT in internal (
>>>> http://febuild1/archiva/repository/internal/) -> [Help 1]
>>>> [...]
>>>> 
>>>> 
>>>> Any ideas how to use SNAPSHOT artifact from the deploy.snapshots
>> repository
>>>> from Archiva?
>>>> 
>>>> Thx in advance,
>>>> Martin
>>>> 
>> 
>> --
>> Brett Porter
>> brett@apache.org
>> http://brettporter.wordpress.com/
>> http://au.linkedin.com/in/brettporter
>> 
>> 
>> 
>> 
>> 

--
Brett Porter
brett@apache.org
http://brettporter.wordpress.com/
http://au.linkedin.com/in/brettporter





Mime
View raw message