archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Mylonas <ch...@opencsta.org>
Subject Authorization Denied for archiva-read-repository permission from maven
Date Wed, 09 Feb 2011 06:30:50 GMT
Hello List,

I'm following a book about maven and have set up a repository manager in
archiva - this user works when logging in via the web UI and also when
browsing directly to
archiva/repository/snapshots/..../1.0-SNAPSHOT/maven-metadata.xml (prompts
for username and password and these also work).

This is the log from archiva.log

Caused by: org.apache.maven.wagon.authorization.AuthorizationException:
Access denied to:
http://tour.opencsta.org:8080/archiva/repository/snapshots/org/opencsta/stack/1.0-SNAPSHOT/maven-metadata.xml

Helpppppppppp please!!

1.  I've set a "master password"  and have put it in the
~/.m2/settings-security.xml file like so:

<settingsSecurity>
  <master>{yyyyencyptedMasterPasswordyyyy=}</master>
</settingsSecurity>

Don't know exactly what it's for and think

2.  I've set my user password in the ~/.m2/conf/settings.xml file like so

<settings xmlns="http://maven.apache.org/SETTINGS/1.0.0"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0
                      http://maven.apache.org/xsd/settings-1.0.0.xsd">
  <localRepository/>
  <interactiveMode/>
  <usePluginRegistry/>
  <offline/>
  <pluginGroups/>
  <servers>
    <server>
      <id>snapshots</id>
      <username>username4chris</username>
      <password>{xxxxencyptedpasswordxxxx=}</password>
    </server>
  </servers>
  <mirrors/>
  <proxies/>
  <profiles/>
  <activeProfiles/>
</settings>

3.  My pom.xml file has the distribution management set correctly I'm
presuming otherwise the mvn deploy output would be going to the wrong url.

Cheers
Chris

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message