archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: Archiva not working on 64 bit Linux
Date Sun, 05 Dec 2010 23:06:48 GMT
I think someone has filed it already, but I'm not sure. It'd be worth making sure this is in
JIRA, and if there's an existing issue watching / voting / patching it.

Cheers,
Brett

On 04/12/2010, at 3:06 PM, ezzekel wrote:

> 
> Confirmed!
> 
> When run the script /bin/./archiva start it informs me that 
> 
> Starting Apache Archiva...
> archiva: line 421: /opt/archiva/bin/./wrapper-linux-x86-32: Not found
> 
> And the file exist!
> I deleted the files /lib/libwrapper-linux-x86-32.so and
> /bin/wrapper-linux-x86-32 and it work again.
> 
> I dont know if it is ussefull but I had the same problem after having some
> problems in my server (disk full). My version of archiva is 1.3.1 running on
> debian lenny 64 bits.
> 
> Really Thanks!
> 
> 
> wild_oscar wrote:
>> 
>> On a follow up, I managed to make it work:
>> 
>> I simply deleted the /lib/libwrapper-linux-x86-32.so and
>> /bin/wrapper-linux-x86-32 files.
>> 
>> Perhaps brett and the rest of the team can figure out why this is needed
>> and, if confirmed, add this to the wiki instructions.
>> 
>> Thanks to Babak Shafian and his post at
>> http://www.mail-archive.com/users@continuum.apache.org/msg01688.html
>> 
>> wild_oscar wrote:
>>> 
>>> Hi,
>>> 
>>> I tried running archiva on an Ubuntu 9.04 64 bits:
>>> 
>>> 1) Downloaded version 1.2.2
>>> 2) Untared it
>>> 3) ran ./bin/archiva console
>>> 
>>> But I get:
>>> 
>>> eval: 1:
>>> /home/mike/Software/archiva/apache-archiva-1.2.2/bin/./wrapper-linux-x86-32:
>>> not found
>>> 
>>> I do have some wrapper-linux files on archiva's root directory; including
>>> 32 and 64 ones. I've chmod them to 777, but no luck: I can't seem to be
>>> able to run it!
>>> 
>>> 
>>> Has anyone successfully run archiva in these conditions, or is otherwise
>>> able to help me out?
>>> Thank you!
>>> 
>>> 
>> 
>> 
> 
> -- 
> View this message in context: http://old.nabble.com/Archiva-not-working-on-64-bit-Linux-tp25789891p30366621.html
> Sent from the archiva-users mailing list archive at Nabble.com.
> 

--
Brett Porter
brett@apache.org
http://brettporter.wordpress.com/


Mime
View raw message