archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Retter <adam.ret...@googlemail.com>
Subject Re: Strange deploy problem
Date Tue, 01 Dec 2009 09:55:10 GMT
2009/11/30 Brett Porter <brett@porterclan.net>:
> Something is causing the indexing to fail, which would make the deployment return an
error (though the artifact is probably already there).

Yes, sometimes archives make it into the repository/snapshots folder
and sometimes they dont.


> Is there any other exceptions in the logs that might help diagnose it? You might want
to remove the indexes (this is described on the web site) to get a clean slate.

>From what I can tell I dont have any indexes at all, I have two empty folders -

/HCR_SubVersion/archiva.new/data/repositories/internal/.indexer/
/HCR_SubVersion/archiva.new/data/repositories/snapshots/.indexer/

I should also mention that /HCR_SubVersion is a network mount, but the
account that Archiva runs under has full access to that mount, as also
proven by the fact that Archiva has been able to add some artifacts to
the snapshots repository.

> The upcoming 1.2.3 release has improvements to the indexing error reporting, and the
ability to rebuild the indexes from the UI that might be helpful. If you'd like to help us
test it, ping us on dev@archiva.apache.org.

I would be happier running 1.2.2 if we can get it running until there
is a stable release of 1.2.3. Lets see if we can get this working,
otherwise I may have to look at 1.2.3-beta.

Thanks Adam.

> Thanks,
> Brett
>
> On 01/12/2009, at 4:12 AM, Adam Retter wrote:
>
>> Hi there I have just installed 1.2.2 on Linux and am trying to deploy
>> to the snapshot repository but I get the Exception below on the server
>> side. I have been fiddling with this all day, but as yet with no
>> success, could someone take a look please?
>>
>> I am calling "mvn deploy" with the following in settings.xml -
>>
>> <server>
>> <id>internal</id>
>> <username>admin</username>
>> <password>myPassword</password>
>> </server>
>> <server>
>> <id>snapshots</id>
>> <username>admin</username>
>> <password>myPassword</password>
>> </server>
>>
>> <profile>
>>                        <id>archiva.new</id>
>>                        <activation>
>>                                    <activeByDefault>true</activeByDefault>
>>                        </activation>
>>                        <repositories>
>>                                    <repository>
>>
>> <id>uk.co.landmark.solutions.maven.internal</id>
>>                                                <name>Landmark
>> Solutions Internal Repository</name>
>>
>> <url>http://exsubv02:8080/archiva/repository/internal</url>
>>                                                <releases>
>>
>> <enabled>true</enabled>
>>                                                </releases>
>>                                                <snapshots>
>>
>> <enabled>false</enabled>
>>                                                </snapshots>
>>                                    </repository>
>>                                    <repository>
>>
>> <id>uk.co.landmark.solutions.maven.snapshots</id>
>>                                                <name>Landmark
>> Solutions Snapshots Repository</name>
>>
>> <url>http://exsubv02:8080/archiva/repository/snapshots</url>
>>                                                <releases>
>>
>> <enabled>false</enabled>
>>                                                </releases>
>>                                                <snapshots>
>>
>> <enabled>true</enabled>
>>                                                </snapshots>
>>                                    </repository>
>>                        </repositories>
>>                        <pluginRepositories>
>>                                    <pluginRepository>
>>
>> <id>uk.co.landmark.solutions.maven.internal.plugin</id>
>>                                                <name>Landmark
>> Solutions Internal Plugin Repository</name>
>>
>> <url>http://exsubv02:8080/archiva/repository/internal</url>
>>                                                <releases>
>>
>> <enabled>true</enabled>
>>                                                </releases>
>>                                                <snapshots>
>>
>> <enabled>false</enabled>
>>                                                </snapshots>
>>                                    </pluginRepository>
>>                                    <pluginRepository>
>>
>> <id>uk.co.landmark.solutions.maven.snapshots.plugin</id>
>>                                                <name>Landmark
>> Solutions Snapshots Plugin Repository</name>
>>
>> <url>http://exsubv02:8080/archiva/repository/snapshots</url>
>>                                                <releases>
>>
>> <enabled>false</enabled>
>>                                                </releases>
>>                                                <snapshots>
>>
>> <enabled>true</enabled>
>>                                                </snapshots>
>>                                    </pluginRepository>
>>                        </pluginRepositories>
>>            </profile>
>>
>>
>> And this in my pom.xml -
>>
>> <distributionManagement>
>>   <repository>
>>      <id>internal</id>
>>      <url>http://exsubv02:8080/archiva/repository/internal</url>
>>    </repository>
>>    <snapshotRepository>
>>        <id>snapshots</id>
>>        <url>http://exsubv02:8080/archiva/repository/snapshots</url>
>>    </snapshotRepository>
>>  </distributionManagement>
>>
>>
>> 2009-11-30 13:47:24,328 [btpool0-3] INFO
>> org.apache.maven.archiva.security.ArchivaServletAuthenticator  -
>> Authorization Denied
>> [ip=192.168.2.24,permission=archiva-upload-repository,repo=snapshots]
>> : no matching permissions
>> 2009-11-30 13:47:27,923 [btpool0-8] INFO
>> org.apache.maven.archiva.security.ArchivaServletAuthenticator  -
>> Authorization Denied
>> [ip=192.168.2.24,permission=archiva-upload-repository,repo=snapshots]
>> : no matching permissions
>> 2009-11-30 13:47:30,855 [pool-3-thread-1] ERROR
>> org.apache.maven.archiva.scheduled.executors.ArchivaIndexingTaskExecutor
>> - Error occurred while executing indexing task
>> 'indexing-job:snapshots:Registers-Common-Current-20091130.155338-2.jar:add'
>> 2009-11-30 13:47:30,929 [pool-3-thread-1] ERROR
>> taskQueueExecutor#indexing  - Error executing task
>> org.codehaus.plexus.taskqueue.execution.TaskExecutionException: Error
>> occurred while executing indexing task
>> 'indexing-job:snapshots:Registers-Common-Current-20091130.155338-2.jar:add'
>>       at org.apache.maven.archiva.scheduled.executors.ArchivaIndexingTaskExecutor.executeTask(ArchivaIndexingTaskExecutor.java:163)
>>       at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
>>       at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
>>       at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
>>       at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:987)
>>       at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:528)
>>       at java.lang.Thread.run(Thread.java:675)
>> 2009-11-30 13:47:31,084 [pool-3-thread-1] ERROR
>> org.apache.maven.archiva.scheduled.executors.ArchivaIndexingTaskExecutor
>> - Error occurred while executing indexing task
>> 'indexing-job:snapshots:Registers-Common-Current-20091130.155338-2.jar.md5:add'
>> 2009-11-30 13:47:31,085 [pool-3-thread-1] ERROR
>> taskQueueExecutor#indexing  - Error executing task
>> org.codehaus.plexus.taskqueue.execution.TaskExecutionException: Error
>> occurred while executing indexing task
>> 'indexing-job:snapshots:Registers-Common-Current-20091130.155338-2.jar.md5:add'
>>       at org.apache.maven.archiva.scheduled.executors.ArchivaIndexingTaskExecutor.executeTask(ArchivaIndexingTaskExecutor.java:163)
>>       at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
>>       at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
>>       at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
>>       at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:987)
>>       at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:528)
>>       at java.lang.Thread.run(Thread.java:675)
>> 2009-11-30 13:47:31,196 [pool-3-thread-1] ERROR
>> org.apache.maven.archiva.scheduled.executors.ArchivaIndexingTaskExecutor
>> - Error occurred while executing indexing task
>> 'indexing-job:snapshots:Registers-Common-Current-20091130.155338-2.jar.sha1:add'
>> 2009-11-30 13:47:31,197 [pool-3-thread-1] ERROR
>> taskQueueExecutor#indexing  - Error executing task
>> org.codehaus.plexus.taskqueue.execution.TaskExecutionException: Error
>> occurred while executing indexing task
>> 'indexing-job:snapshots:Registers-Common-Current-20091130.155338-2.jar.sha1:add'
>>       at org.apache.maven.archiva.scheduled.executors.ArchivaIndexingTaskExecutor.executeTask(ArchivaIndexingTaskExecutor.java:163)
>>       at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
>>       at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
>>       at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
>>       at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:987)
>>       at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:528)
>>       at java.lang.Thread.run(Thread.java:675)
>>
>>
>>
>> --
>> Adam Retter
>>
>> skype :adam.retter
>> http://www.adamretter.org.uk
>
>



-- 
Adam Retter

skype :adam.retter
http://www.adamretter.org.uk

Mime
View raw message