archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ian Dees <ian.d...@ge.com>
Subject Re: Strange Proxy Behavior
Date Wed, 16 Dec 2009 23:27:02 GMT
Ok, I believe there is still an issue with this. Some more specifics:

I'm running maven via the m2eclipse plugin, have an Archiva server at
http://url:8080/archiva mirroring central, and also have the following
in my ~/.m2/settings.xml:

...
   <mirror>
      <id>archiva.central</id>
      <url>http://url:8080/archiva/repository/internal</url>
      <mirrorOf>central</mirrorOf>
   </mirror>
...

When I attempt to run the "install" maven goal, it can not resolve the
maven-resources-plugin:2.4.1 (which clearly exists on repo1).

archiva.log shows me:


On Wed, 2009-12-16 at 16:14 -0600, Ian Dees wrote:
> The corporate overlords here recently started blocking the official
> Maven repo, so Archiva was getting 403 Forbidden when it tried to hit
> the repo. I changed the proxy to one that works now, but Archiva refuses
> to forget that it has got a 403 last time it touched central.
> 
> How can I get it to hit the repo and realize that it is OK to use the
> new proxy now?


Mime
View raw message