archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: Plugins through proxied repo
Date Mon, 22 Dec 2008 01:00:31 GMT
Very strange - it seems like perhaps Maven is not using the correct  
user/password in this instance.

- Brett

On 19/12/2008, at 2:55 AM, Raphael Parree wrote:

> Brett,
>
> Yes "scott" has observer access and the URL is correct. Other  
> artefacts (non
> plugin) are obtained normal (and even downloaded by the archiva  
> server if
> needed)
>
> tx.,
>
>
> On Thu, Dec 18, 2008 at 4:38 PM, Brett Porter <brett@apache.org>  
> wrote:
>
>> Are you able to access the URL of the mirror in the browser using
>> scott:tiger? Does scott have "observer" access to the internal  
>> repository?
>>
>> Cheers,
>> Brett
>>
>>
>> On 18/12/2008, at 10:50 PM, Raphael Parree wrote:
>>
>> Hi,
>>>
>>> I have Archiva 1.2-M1 running. With default repos and default  
>>> proxies. I
>>> have setup a mirror:
>>>
>>> <server>
>>> <id>foo</id>
>>> <username>scott</username>
>>> <password>tiger</password>
>>> </server>
>>> ...
>>> <mirror>
>>> <id>foo</id>
>>> <url>http://....</url>
>>> <mirrorOf>*</mirrorOf>
>>> </mirror>
>>>
>>> I have tried both with and without the pluginRepositories  
>>> configuration
>>> below
>>>
>>> <profile>
>>> <id>Repository Proxy</id>
>>> <activation>
>>> <activeByDefault>true</activeByDefault>
>>> </activation>
>>> <pluginRepositories>
>>> <pluginRepository>
>>>  <id>foo</id>
>>>   <releases>
>>>     <enabled>true</enabled>
>>>   </releases>
>>>   <snapshots>
>>>     <enabled>true</enabled>
>>>   </snapshots>
>>>   <url>http://...</url>
>>> </pluginRepository>
>>> </pluginRepositories>
>>>
>>>
>>> I have removed the directory from the local repo, but i keep on
>>> getting:"The
>>> plugin 'org.apache.maven.plugins:maven-eclipse-plugin' does not  
>>> exist or
>>> no
>>> valid version could be found"
>>>
>>> Without the above pluginRepository config in the profile i see a  
>>> log entry
>>> in Archiva:
>>> INFO   
>>> org.apache.maven.archiva.security.ArchivaServletAuthenticator  -
>>> Authorization Denied
>>>
>>> [ip=90...,isWriteRequest=false,permission=archiva-read- 
>>> repository,repo=internal]
>>> : no matching permissions
>>>
>>> The plugin is indeed still not in Archiva, but s far it has been  
>>> obtaining
>>> jars and plugins via the proxy settings.
>>>
>>> What am i missing?
>>>
>>> tx.,
>>>
>>>
>>>
>>> --
>>> Raphael
>>>
>>
>> --
>> Brett Porter
>> brett@apache.org
>> http://blogs.exist.com/bporter/
>>
>>
>
>
> -- 
> Raphael Parree
> CTO
> SOA Evangelist
>
> phone +33 683 468663
> Disclaimer...
> "The information contained in this message may be confidential and is
> intended to be exclusively for the addressee. Sender's written  
> permission is
> needed prior to forwarding or otherwise using the content of the  
> message,
> whether completely or partially. Should you receive this message
> unintentionally, please do not use the contents herein and notify  
> the sender
> immediately by return e-mail. Please rely on your own virus  
> checking, no
> responsibility is taken by the sender for any damage rising out of  
> any bug
> or virus infection."

--
Brett Porter
brett@apache.org
http://blogs.exist.com/bporter/


Mime
View raw message