archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brett Porter" <brett.por...@gmail.com>
Subject Re: Deploy artifact to archiva for the first time - error
Date Fri, 28 Mar 2008 08:51:43 GMT
I think this is a result of not having permissions to write that file
on the server

On 28/03/2008, Paul G <ps.grove@googlemail.com> wrote:
>
>  I have just set Archiva as per the docs my build works fine all the artifacts
>  are downloaded within Archiva. But when I come to deploy to a newly created
>  repository managed by Archiva using web dav I get the following error
>  [INFO] Error deploying artifact: Resource to deploy not found: File:
>  http://localhost:8800/archiva/repository/team_snapshot/psg/scratch/beanUtils/BeanUtilsEx/0.0.1-SNAPSHOT/BeanUtilsEx-0.0.1-20080327.223426-1.jar
>  does not exist
>
>  This is my pom file
>  <distributionManagement>
>                 <repository>
>                         <id>archiva.team.release</id>
>                         <name>Internal Release Repository</name>
>                         <url>
>                                 dav:http://localhost:8800/archiva/repository/team_release/
>                         </url>
>                 </repository>
>                 <snapshotRepository>
>                         <id>archiva.team.snapshot</id>
>                         <name>Internal Snapshot Repository</name>
>                         <url>
>                                 dav:http://localhost:8800/archiva/repository/team_snapshot/
>                         </url>
>                 </snapshotRepository>
>         </distributionManagement>
>
>  Why is webdav complaining the artifact is not found, surely it is not there
>  as it is the first time I have deployed?
>  Help I'm confused. Below is the full stack trace when running in debug.
>  [INFO] Error deploying artifact: Resource to deploy not found: File:
>  http://loca
>  lhost:8800/archiva/repository/team_snapshot/psg/scratch/beanUtils/BeanUtilsEx/0.
>  0.1-SNAPSHOT/BeanUtilsEx-0.0.1-20080327.224101-1.jar does not exist
>
>  [INFO]
>  ------------------------------------------------------------------------
>  [INFO] Trace
>  org.apache.maven.lifecycle.LifecycleExecutionException: Error deploying
>  artifact
>  : Resource to deploy not found: File:
>  http://localhost:8800/archiva/repository/t
>  eam_snapshot/psg/scratch/beanUtils/BeanUtilsEx/0.0.1-SNAPSHOT/BeanUtilsEx-0.0.1-
>  20080327.224101-1.jar does not exist
>         at
>  org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(Defa
>  ultLifecycleExecutor.java:564)
>         at
>  org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLi
>  fecycle(DefaultLifecycleExecutor.java:480)
>         at
>  org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(Defau
>  ltLifecycleExecutor.java:459)
>         at
>  org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHan
>  dleFailures(DefaultLifecycleExecutor.java:311)
>         at
>  org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegmen
>  ts(DefaultLifecycleExecutor.java:278)
>         at
>  org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLi
>  fecycleExecutor.java:143)
>         at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:333)
>         at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:126)
>         at org.apache.maven.cli.MavenCli.main(MavenCli.java:282)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at
>  sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
>  java:39)
>         at
>  sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
>  sorImpl.java:25)
>         at java.lang.reflect.Method.invoke(Method.java:585)
>         at
>  org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
>         at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
>         at
>  org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
>
>         at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
>  Caused by: org.apache.maven.plugin.MojoExecutionException: Error deploying
>  artif
>  act: Resource to deploy not found: File:
>  http://localhost:8800/archiva/repositor
>  y/team_snapshot/psg/scratch/beanUtils/BeanUtilsEx/0.0.1-SNAPSHOT/BeanUtilsEx-0.0
>  .1-20080327.224101-1.jar does not exist
>         at
>  org.apache.maven.plugin.deploy.DeployMojo.execute(DeployMojo.java:174
>  )
>         at
>  org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPlugi
>  nManager.java:447)
>         at
>  org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(Defa
>  ultLifecycleExecutor.java:539)
>         ... 16 more
>  Caused by: org.apache.maven.artifact.deployer.ArtifactDeploymentException:
>  Error
>   deploying artifact: Resource to deploy not found: File:
>  http://localhost:8800/a
>  rchiva/repository/team_snapshot/psg/scratch/beanUtils/BeanUtilsEx/0.0.1-SNAPSHOT
>  /BeanUtilsEx-0.0.1-20080327.224101-1.jar does not exist
>         at
>  org.apache.maven.artifact.deployer.DefaultArtifactDeployer.deploy(Def
>  aultArtifactDeployer.java:94)
>         at
>  org.apache.maven.plugin.deploy.DeployMojo.execute(DeployMojo.java:162
>  )
>         ... 18 more
>  Caused by: org.apache.maven.wagon.TransferFailedException: Resource to
>  deploy no
>  t found: File:
>  http://localhost:8800/archiva/repository/team_snapshot/psg/scratc
>  h/beanUtils/BeanUtilsEx/0.0.1-SNAPSHOT/BeanUtilsEx-0.0.1-20080327.224101-1.jar
>  d
>  oes not exist
>         at
>  org.apache.maven.artifact.manager.DefaultWagonManager.putRemoteFile(D
>  efaultWagonManager.java:276)
>         at
>  org.apache.maven.artifact.manager.DefaultWagonManager.putArtifact(Def
>  aultWagonManager.java:153)
>         at
>  org.apache.maven.artifact.deployer.DefaultArtifactDeployer.deploy(Def
>  aultArtifactDeployer.java:80)
>         ... 19 more
>  Caused by: org.apache.maven.wagon.ResourceDoesNotExistException: File:
>  http://lo
>  calhost:8800/archiva/repository/team_snapshot/psg/scratch/beanUtils/BeanUtilsEx/
>  0.0.1-SNAPSHOT/BeanUtilsEx-0.0.1-20080327.224101-1.jar does not exist
>         at
>  org.apache.maven.wagon.providers.webdav.WebDavWagon.put(WebDavWagon.j
>  ava:302)
>         at
>  org.apache.maven.artifact.manager.DefaultWagonManager.putRemoteFile(D
>  efaultWagonManager.java:237)
>         ... 21 more
>
> --
>  View this message in context: http://www.nabble.com/Deploy-artifact-to-archiva-for-the-first-time---error-tp16339554p16339554.html
>  Sent from the archiva-users mailing list archive at Nabble.com.
>
>


-- 
Brett Porter
Blog: http://blogs.exist.com/bporter/

Mime
View raw message