archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brett Porter" <brett.por...@gmail.com>
Subject Re: Inproper form validation and UI crash
Date Mon, 17 Mar 2008 21:48:56 GMT
the issue for the validation problem is:
http://jira.codehaus.org/browse/MRM-598
We'll endeavour to get that fixed as soon as possible - a workaround
in the mean time is to disable javascript ust long enough to edit the
repositories.

I'm not sure what causes the applet crash, but you can disable the
find artifact feature by editing the uiOptions of archiva.xml

Cheers,
Brett

On 17/03/2008, Lustig, Marc (Allianz Deutschland AG)
<EXTERN.LUSTIG_MARC@allianz.de> wrote:
> addendum 2:
>  the same problem appears running archiva-1.0.1 standalone (jetty):
>
>  1. "Repository Purge By Days Older Than" validation accepts the values 0 and 1 only,
although the webwork-validation file seems to be correct:
>
>  repositoryForm.jspf:
>  <ww:textfield name="repository.daysOlder" label="Repository Purge By Days Older Than"
size="5"/>
>
>  AddManagedRepositoryAction-validation.xml:
>  <field name="repository.daysOlder">
>         <field-validator type="int">
>                 <param name="min">0</param>
>               <param name="max">1000</param>
>                 <message>Repository Purge By Days Older Than needs to be between
${min} and ${max}.</message>
>         </field-validator>
>  </field>
>
>  I suppose the webwork action-method has a bug.
>
>
>  2. clicking menu-item "find artifact" cause both IE6 and firefox2 to crash/close immediately.
>
>
>  Surprisingly, I can't see any JIRA-issue for both matters.
>  Has anybody experienced those problems too?
>
>
>  some correction of my previous mail: the button "add repository" remains functional
(it just appears to be non-functional).
>
>
>  /m
>
>
>  -----Ursprüngliche Nachricht-----
>  Von: Lustig, Marc (Allianz Deutschland AG)
>  Gesendet: Montag, 17. März 2008 10:32
>  An: archiva-users@maven.apache.org
>  Betreff: Inproper form validation and UI crash
>
>
>
> I have installed Archiva on a JBoss 5-beta instance and it seems to
>  start up properly.
>  It's possible to browse the menu and to do a search using Firefox 2.
>
>  When we try to add a repository (button "add repository"), Archiva is
>  complaining about the value for "Repository Purge By Days Older Than"
>  not being in the proper range, which is actually not the case.
>  Furthermore, now the button "add repository" is non-working! It's not
>  possible to send the form anymore. There is no Javascript error
>  reported. The menu is still working.
>  There is no exception in the log-file.
>
>  I heard that other people have experienced similar problems running
>  Archiva on JBoss/Tomcat. Has there been any investigation regarding the
>  cause of this?
>  Any suggestion?
>
>
>  Btw, clicking on the menu "Find Artifact" causes to crash Firefox
>  2.0.0.12 on windows.
>  It seems the AJAX-library that drives archiva is somewhat corrupt.
>
>  /m
>


-- 
Brett Porter
Blog: http://blogs.exist.com/bporter/

Mime
View raw message