archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mick Knutson" <mickknut...@gmail.com>
Subject Re: [archiva 1] Unable to download the artifact from any repository
Date Mon, 14 Jan 2008 20:45:19 GMT
If I go to:
http://rc-sun66e.ut.dentegra.lab:8080/archiva/org/codehaus/mojo/xmlbeans-maven-plugin/2.3.0/xmlbeans-maven-plugin-2.3.0.jar

(I get a 404 Not Found error)

HTTP Status 404 -
/archiva/org/codehaus/mojo/xmlbeans-maven-plugin/2.3.0/xmlbeans-
maven-plugin-2.3.0.jar
------------------------------

*type* Status report

*message* */archiva/org/codehaus/mojo/xmlbeans-maven-plugin/2.3.0/xmlbeans-
maven-plugin-2.3.0.jar*

*description* *The requested resource
(/archiva/org/codehaus/mojo/xmlbeans-maven-plugin/2.3.0/xmlbeans-
maven-plugin-2.3.0.jar) is not available.*


as per the quickstart guide, I should force archiva to download this right?


I have these CFG'd in Archiva:

Maven Central Repository  Identifier central  Name Maven Central Repository
URL http://repo1.maven.org/maven2  Type Maven 2.x Repository    Edit
<http://rc-sun66e.ut.dentegra.lab:8080/archiva/admin/editRemoteRepository.action?repoid=codehaus-snapshot>
Delete
<http://rc-sun66e.ut.dentegra.lab:8080/archiva/admin/confirmDeleteRemoteRepository.action?repoid=codehaus-snapshot>
  Codehaus Snapshot  Identifier codehaus-snapshot  Name Codehaus Snapshot
URL http://snapshots.repository.codehaus.org/  Type Maven 2.x Repository
  Edit
<http://rc-sun66e.ut.dentegra.lab:8080/archiva/admin/editRemoteRepository.action?repoid=maven2-repository.dev.java.net>
Delete
<http://rc-sun66e.ut.dentegra.lab:8080/archiva/admin/confirmDeleteRemoteRepository.action?repoid=maven2-repository.dev.java.net>
  Java.net Repository for Maven 2 Identifier maven2-repository.dev.java.net
Name Java.net Repository for Maven 2  URL http://download.java.net/maven/2/
Type Maven 2.x Repository


On Jan 14, 2008 12:19 PM, Wendy Smoak <wsmoak@gmail.com> wrote:

> On Jan 14, 2008 12:51 PM, Mick Knutson <mickknutson@gmail.com> wrote:
>
> > I have found the xmlbeans plugin from the maven-repository, but archiva
> > can't get it as it does not exist in my mirror:
> >
> >
> > [ERROR] BUILD ERROR
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Failed to resolve artifact.
> >
> > GroupId: org.codehaus.mojo
> > ArtifactId: xmlbeans-maven-plugin
> > Version: 2.3.1
> >
> > Reason: Unable to download the artifact from any repository
> >
> >   org.codehaus.mojo:xmlbeans-maven-plugin:pom:2.3.1
> >
> > from the specified remote repositories:
> >   central (http://repo1.maven.org/maven2),
> >   dap.internal (
> > http://rc-sun66e.ut.dentegra.lab:8080/archiva/repository/internal/),
> >   dap.snapshots (
> > http://rc-sun66e.ut.dentegra.lab:8080/archiva/repository/snapshots/)
> ...
> > Why can't Archiva automatically get the plugin?
>
> It works fine for me.  Archiva 1.0 is able to proxy a request for
> xmlbeans-maven-plugin 2.3.1.
>
> There isn't enough information here for me to guess what's wrong with
> your setup though.  What does the Archiva log file say?
>
> --
> Wendy
>



-- 
Thanks,
Mick Knutson

http://www.baselogic.com
http://www.blincmagazine.com
http://www.djmick.com
http://www.myspace.com/mickknutson
http://www.myspace.com/BLiNCMagazine
http://tahoe.baselogic.com
---

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message