archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mick Knutson" <mickknut...@gmail.com>
Subject [m2][archiva1] Issue deploying to Archiva
Date Mon, 14 Jan 2008 18:27:31 GMT
I can deploy my site docs to my remote server just fine, but when I try to
deploy a module to my archiva REP, I get a 401 error.

*pom.xml:*

        <!-- use the following if you're not using a snapshot version. -->
        <repository>
            <id>dap.internal</id>
            <name>Internal Release Repository</name>
            <url>dav:
http://rc-sun66e.ut.dentegra.lab:8080/archiva/repository/internal/</url>
        </repository>

        <!-- use the following if you ARE using a snapshot version. -->
        <snapshotRepository>
            <id>dap.snapshots</id>
            <name>Internal Snapshot Repository</name>
            <url>dav:
http://rc-sun66e.ut.dentegra.lab:8080/archiva/repository/snapshots/</url>
        </snapshotRepository>

    </distributionManagement>

    <repositories>
        <repository>
            <id>dap.internal</id>
            <name>Archiva Managed Internal Repository</name>
            <url>
http://rc-sun66e.ut.dentegra.lab:8080/archiva/repository/internal/</url>
            <releases>
                <enabled>true</enabled>
            </releases>
            <snapshots>
                <enabled>false</enabled>
            </snapshots>
        </repository>

        <repository>
            <id>dap.snapshots</id>
            <name>Archiva Managed Snapshot Repository</name>
            <url>
http://rc-sun66e.ut.dentegra.lab:8080/archiva/repository/snapshots/</url>
            <releases>
                <enabled>false</enabled>
            </releases>
            <snapshots>
                <enabled>true</enabled>
            </snapshots>
        </repository>

    </repositories>

    <pluginRepositories>
        <pluginRepository>
            <id>dap.internal</id>
            <name>Archiva Managed Internal Repository</name>
            <url>
http://rc-sun66e.ut.dentegra.lab:8080/archiva/repository/internal/</url>
            <releases>
                <enabled>true</enabled>
            </releases>
            <snapshots>
                <enabled>false</enabled>
            </snapshots>
        </pluginRepository>

        <pluginRepository>
            <id>dap.snapshots</id>
            <name>Archiva Managed Snapshot Repository</name>
            <url>
http://rc-sun66e.ut.dentegra.lab:8080/archiva/repository/snapshots/</url>
            <releases>
                <enabled>false</enabled>
            </releases>
            <snapshots>
                <enabled>true</enabled>
            </snapshots>
        </pluginRepository>
    </pluginRepositories>




*settings.xml:*

    <servers>
        <server>
            <id>rc_sun66e-site</id>
            <username>xxx</username>
            <password>xxx</password>
            <passphrase>xxx</passphrase>
            <privateKey>c:/ssh/rc-sun66e-private.ppk</privateKey>
            <filePermissions>664</filePermissions>
            <directoryPermissions>775</directoryPermissions>
            <configuration>
                <sshExecutable>putty</sshExecutable>
                <scpExecutable>pscp</scpExecutable>
            </configuration>
        </server>

        <server>
            <id>rc_sun66e-repository</id>
            <username>xxx</username>
            <password>xxx</password>
            <passphrase>xxx</passphrase>
            <privateKey>c:/ssh/rc-sun66e-private.ppk</privateKey>
            <filePermissions>664</filePermissions>
            <directoryPermissions>775</directoryPermissions>
            <configuration>
                <sshExecutable>plink</sshExecutable>
                <scpExecutable>pscp</scpExecutable>
            </configuration>
        </server>

        <server>
            <id>dap2.internal</id>
            <username>xxx</username>
            <password>xxx</password>
            <passphrase>xxx</passphrase>
            <privateKey>c:/ssh/rc-sun66e-private.ppk</privateKey>
            <filePermissions>664</filePermissions>
            <directoryPermissions>775</directoryPermissions>
            <configuration>
                <sshExecutable>plink</sshExecutable>
                <scpExecutable>pscp</scpExecutable>
            </configuration>
        </server>

        <server>
            <id>deployment.webdav</id>
            <username>xxx</username>
            <password>xxx</password>
            <passphrase>xxx</passphrase>
            <privateKey>c:/ssh/rc-sun66e-private.ppk</privateKey>
            <filePermissions>664</filePermissions>
            <directoryPermissions>775</directoryPermissions>
            <configuration>
                <sshExecutable>plink</sshExecutable>
                <scpExecutable>pscp</scpExecutable>
            </configuration>
        </server>

<!--I also tried this instead of the above server but no change:-->
        <!--<server>
            <id>deployment.webdav</id>
            <username>[archiva-username]</username>
            <password>xxxx</password>
        </server>-->

...

        <mirror>
            <id>dap.internal</id>
            <url>
http://rc-sun66e.ut.dentegra.lab:8080/archiva/repository/internal/</url>
            <mirrorOf>*</mirrorOf>
        </mirror>



-- 
Thanks,
Mick Knutson

http://www.baselogic.com
http://www.blincmagazine.com
http://www.djmick.com
http://www.myspace.com/mickknutson
http://www.myspace.com/BLiNCMagazine
http://tahoe.baselogic.com
---

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message