archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brett Porter" <brett.por...@gmail.com>
Subject Re: Archiva freeze because of down site ?
Date Thu, 20 Dec 2007 20:44:41 GMT
Yeah, improvements to the caching should certainly be filed as a
feature request - and we should run through the plan on the dev@ list
if possible.

As far s your original freezing problem goes - I assigned it to the
1.0.1 version yesterday. I've seen another report too and they are
helping to diagnose what the cause is. I had a suspicion it might be
because of remote repository connections - I think this evidence is
starting to confirm that.

- Brett

On 21/12/2007, nicolas de loof <nicolas@apache.org> wrote:
> "Cache failure" option is supposed (AFAIK) to enable such caching, and avoid
> requesting again and again the same repository, where 404 or timeout occurs.
>
> Reading the code, (DefaultRepositoryProxyConnectors) seems the cache is not
> used before requesting a proxyConnector for an artifact. 404 also are not
> cached, and IMHO they should for performance consideration (exemple : many
> artifact have no -sources.jar, but are requested by IDE plugins).
>
> The cache configuration is also hardcoded in archiva-policies. Not sure it
> will fit the requirements for all users and use-cases (missing artifact,
> network connection borken ...).
>
> I'll look at this tomorow, could you please fill an issue in Jira ?
>
> Nico.
>
>
> 2007/12/20, Julien CARSIQUE <jcarsique@nuxeo.com>:
> >
> > Hello,
> >
> > Today, archiva was (again freezed) but restart didn't solve the problem.
> > Looking in the logs, I saw that one of our remote repositories was dead;
> > removing it solved the problem.
> > Archiva do not cache information about unavailable site to not calling
> > it for each artifact ?
> > Could be a useful improvement ?
> >
> > PS: I didn't have any answer about my mail "Cannot use archiva browse
> > function after 2 days running"; we still have to restart archiva every
> > one, two or three days because it freezes. Please, help would be very
> > welcome; thanks.
> >
> > This morning, Archiva was freezed again; here's the top on the server :
> > PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+
> > 25619 archiva   19   0      209m 186m 103m R 17.0     21.1      53:14.14
> >
> > 25751 archiva   20   0      209m 186m 103m R 16.8     21.1      47:34.28
> >
> > 28163 archiva   14   0      209m 186m 103m S 16.6     21.1      40:42.57
> >
> > 28124 archiva   14   0      209m 186m 103m S 16.4     21.1      41:44.36
> >
> > 26348 archiva   19   0      209m 186m 103m R 15.7     21.1      43:01.91
> >
> > --
> > Julien CARSIQUE, Nuxeo (Paris, France)
> > Open Source Enterprise Content Management - http://www.nuxeo.org/
> > Nuxeo EP 5: extensible, Java EE and standards based ECM Platform
> > http://www.nuxeo.com/ - Tel: +33 1 40 33 79 87
> >
> >
>


-- 
Brett Porter
Blog: http://www.devzuz.org/blogs/bporter/

Mime
View raw message