archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexey Kakunin" <akaku...@gmail.com>
Subject Problems with deploying file into archiva
Date Mon, 19 Feb 2007 14:16:01 GMT
Hello!
I just checked out and built latest version of archiva and tried to use.
First I tried to make it working under Tomcat.... in general it started to
work - but...
Finally I decied to switch to archiva-plexus-runtime  -about tomcat problems
I will write a little bit later.

So, under as plexus runtime it started to work much better - I created
repository xxx, I created user and assigned roles for this user:
Repository Manager - xxx
Repository Observer - xxx

I can open my http://my.server.com:8091/archiva/repository/xxx/ quite well
as this user and browse it. But, then I'm trying to deploy file into
repository with using:
mvn deploy:deploy-file -DrepositoryId=xxxMavenRepo -Durl=
http://my.server.com:8091/archiva/repository/xxx/ -DgroupId= .....

I've got error 409.

In the archiva logs I found followed:

------------------------------------------------------------------------
Feb 19, 2007 4:42:06 PM org.mortbay.jetty.servlet.ServletHandler$Context log
INFO: RepositoryServlet: Authorization Denied
[ip=192.168.2.118,isWriteRequest=true,permission=archiva-upload-repository]
: no matching permissions
-->>> request ----------------------------------------------------------
--> http://my.server.com:8091/repository
PUT /archiva/repository/xxx/jspwiki/java2html/2.4.6/java2html-2.4.6.jar HTTP/1.1
User-Agent: Java/1.5.0_06
Host: www.emforge.org:8091
Accept: text/html, image/gif, image/jpeg, *; q=.2, */*; q=.2
Connection: keep-alive
Content-Length: 192282
Authorization: Basic YWtha3VuaW46ZW1mMHJnZQ==



It seems like user I'm using for uploading has no right for upload (I
specified user name and password in maven2 settings.xml).

I'm using Linux as server and WinXP as client. Seems I missed something in
configuration - could anybody point me?


-- 
With Best Regards,
Alexey Kakunin, EmDev Limited

Professional Software Development:
http://www.emdev.ru

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message