archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From drekka <>
Subject Re: Archiva deployment on Jetty?
Date Thu, 04 Jan 2007 03:16:26 GMT

How did you get it going ? I tried this as per the example here and on the
FAQ and it was a complete failure. Here's what I did:

1. Install the j2ee connector.
2. Checkout the svn repository to my local machine.
3. in eclipse, did a maven2 install to build it.
4. On the target machine, installed jetty 6.0.2 and wiped it's webapps
directory. Didn't do anything else.
5. Uploaded archiva-webapp/target/ to the target machines
jetty-6.0.2/webapps directory.
6. unwar'd the war.
7. updated etc/jetty.xml to a port of 2222.
8. Step 5 - copy jetty-env.xml - where is it ???? 
9. Found jetty-env.xml in my local machines archiva-webapp/src and uploaded
it to jetty-6.0.2/webapps/archiva/WEB-INF. Why wasn't this in the war ????
10. Ran the startup command.
11. Got messages about failures to find JNDI datasources but they appear to
be related to test-jndi webapp.
12. Opened target machines port 2222/archiva
13. Got a bunch of exceptions with the main cause being that the JNDI name
env/jdbc/users was not found.

So how do I fix this ??? It looks very much to me like the instructions as
given are incomplete and make assumptions about the war, or the jetty setup
or the machine or something. 


Joakim Erdfelt-2 wrote:
> I have it working with jetty 6.0.2
> 1) downloaded jetty 6.0.2
> 2) installed default jetty 6.0.2
> 3) removed all content under webapps/*
> 4) unpacked archiva war file into webapps/archiva/
> 5) copied jetty-env.xml into webapps/archiva/WEB-INF/jetty-env.xml
> 6) modified default port in jetty.xml
> 7) Started up with following command.
> [archiva@~/java/jetty-6.0.2]$ java -Xmx256m -jar start.jar etc/jetty.xml
> etc/jetty-plus.xml
> NOTE: The jetty-plus configuration is *REQUIRED* to get jndi binding to
> work.
> - Joakim Erdfelt
> Max Bowsher wrote:
>> Does anyone have a working configuration of Archiva deployed on Jetty,
>> for which they'd be willing to share the Jetty config files?
>> (I'm referring to deployment on a standalone Jetty, here, rather than
>> testing via maven-jetty-plugin).
>> I've tried to get this working myself, but only succeeded by configuring
>> the JNDI datasource stuff via WEB-INF/jetty-env.xml. When I try to move
>> that configuration to the main Jetty config so that I do not have to
>> poke around inside the Archiva war, I can't get the JNDI bindings to
>> work right.
>> Thanks,
>> Max.

View this message in context:
Sent from the archiva-users mailing list archive at

View raw message