archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Horwitz" <mike.horw...@gmail.com>
Subject Re: Giving up on Archiva
Date Fri, 05 Jan 2007 09:46:07 GMT
Hi,

Got to share some of the frustrations in setting things up - took a while to
learn which was the correct URL to use to access a repository, but once that
was sorted out Archiva is up and running and works as expected. It has been
an asset to our build environment.

Mike.


On 1/5/07, drekka <derek.clarkson@aegeon.com.au> wrote:
>
>
> Hi all
>
> I've now been struggling with Archiva for over two days and we are going
> to
> drop it. All we wanted to do was:
>
> 1. Have a local company repository so that we can centrally store built
> artifacts such as jars.
> 2. Have requests for artifacts from central automatically cached in the
> repository so that when the next programmer requests it, it is downloaded
> from there rather than across the net. I.e. proxying central.
>
> Relatively speaking these should have been a piece of cake to setup.
> Wrong.
> The first thing I tried was to setup a copy of the archiva war as per the
> instructions on a number of sites. This totally failed. A core file was
> missing from the war and even after I manually copied it to the un-warred
> directories on the linux box, archiva still refused to boot up. Gave up on
> this after a day of frustration.
>
> Next I uploaded the archiva command line version (almost not doco'd
> anywhere!). This iimediately worked and didn't have to be run in
> conjuction
> with a web server. Much easier to setup and use. I created a company
> respository and then a proxy of ibiblio which used the company repository
> for storage.
>
> Next I started to look at how to refer to the proxy to get common stuff
> such
> as commons-logging and log4j, etc. Here again I ran into poorly written
> documentation and ended up wasting another day trying to get it to work. I
> tried all sorts of configurations including adding stuff to settings.xmland
> to the poms. Repositories referring to the company repository, the proxy,
> mirror settings, profiles, everything I could find and all sorts of
> variations on them. The only thing I could get to work was if I manually
> added an artifact (junit for example) to the repository directories, I
> could
> then see it and have the dependencies resolved and the jar downloaded
> rather
> than from central. At no stage though, could I get the proxy functionality
> to work. Accessing the proxies via the /proxy/<id> links totally failed to
> resolve. No errors where logged either. The logs (now in debug) showed the
> proxy code firing, failing to find the artifacts and apparently just
> exiting. Not going to the company repository the proxy was pointed at or
> ibiblio.
>
> To aggravate this further looking into the source code for archiva I found
> that the proxy managers sourc code exist sin two different projects !!
> It's
> code 's got practically zero documentation and debug which explained why
> turning on debug did little in the way of helping out with diagnosing the
> issue.
>
> So basically I just don't have the time to keep trying to use this.
> Perhaps
> in a version or two I'll take another look.
>
> ciao
> Derek
>
> --
> View this message in context:
> http://www.nabble.com/Giving-up-on-Archiva-tf2923923.html#a8173057
> Sent from the archiva-users mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message