ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aleksandar Kurtakov <akurt...@redhat.com>
Subject Re: Buliding IvyDE
Date Fri, 13 Sep 2019 12:59:32 GMT
On Fri, Sep 13, 2019 at 3:55 PM Tim Astle <timothy.astle@gmail.com> wrote:

> I have the latest version of Eclipse, and unfortunately there isn't a
> version of IvyDE that works with it.
>
> I'm not sure if there will be a version made available, so I attempted
> to build it myself following this document:
>
> https://github.com/apache/ant-ivyde/blob/master/doc/src/dev/build.adoc
>
> I checked out the 2.3.0-rc1 tag (dunno, figured it's the right one)
> and grabbed this version of Eclipse:
>
> https://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/2019-06/R/eclipse-committers-2019-06-R-linux-gtk-x86_64.tar.gz&mirror_id=1249
>
> I created a local.build.properties that points to the unpacked distro
> above.
>
> I ran `ant install-ivy`
>
> Then when I ran `ant build`, I get the following:
>
> [pde-build]
> /home/tastle/Downloads/eclipse/plugins/org.eclipse.pde.build_3.10.400.v20190320-1020/scripts/genericTargets.xml:112:
> Processing inclusion from feature
> org.apache.ivyde.eclipse.resolvevisualizer.feature: Bundle
> org.apache.ivyde.eclipse.resolvevisualizer_2.3.0.rc1-201909130952-dev
> failed to resolve.:
> [pde-build] Missing required plug-in org.eclipse.zest.core_[1.5.0,2.0.0).
> [pde-build] Missing required plug-in
> org.eclipse.zest.layouts_[1.1.0,2.0.0).
> [pde-build]
> [pde-build]
> [pde-build] Total time: 1 second
> [pde-build] [eclipse.buildScript] Some inter-plug-in dependencies have
> not been satisfied.
> [pde-build] [eclipse.buildScript] Bundle
> org.apache.ivyde.eclipse.resolvevisualizer:
> [pde-build] [eclipse.buildScript] Missing required plug-in
> org.eclipse.zest.core_[1.5.0,2.0.0).
> [pde-build] [eclipse.buildScript] Missing required plug-in
> org.eclipse.zest.layouts_[1.1.0,2.0.0).
> [pde-build] [eclipse.buildScript] Bundle org.eclipse.epp.logging.aeri.ide:
> [pde-build] [eclipse.buildScript] Unsatisfied import package
> org.apache.lucene.document_[7.1.0,8.0.0).
> [pde-build] [eclipse.buildScript] Unsatisfied import package
> org.apache.lucene.index_[7.1.0,8.0.0).
> [pde-build] [eclipse.buildScript] Unsatisfied import package
> org.apache.lucene.search_[7.1.0,8.0.0).
> [pde-build] [eclipse.buildScript] Unsatisfied import package
> org.apache.lucene.store_[7.1.0,8.0.0).
> [pde-build] An error has occurred. See the log file
> [pde-build] /home/tastle/workspace/.metadata/.log.
>
> BUILD FAILED
> /home/tastle/Dev/Code/ant-ivyde/build.xml:179: Java returned: 13
>
> Did I get the wrong distribution, or are the build instructions incorrect?
>
> All I really want is IvyDE in the Eclipse Marketplace for the latest
> version of eclipse...
>

Eclipse IDE has been moved to use lucene 8.x thus IvyDE has to be adapted
too.


>
>
> Tim
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
> For additional commands, e-mail: dev-help@ant.apache.org
>
>

-- 
Alexander Kurtakov
Red Hat Eclipse Team

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message