ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: Unintentional broken compatibility of Ant 1.10.6 with Java 8
Date Fri, 24 May 2019 04:26:11 GMT
On 2019-05-24, Jaikiran Pai wrote:

> As you all might know, we released Ant 1.10.6 some days back. That
> release was built using Java 11 but targeted to be usable with Java 8
> (our minimum requirement runtime that we support). However, due to a bug
> in our build and release process, we have broken the compatibility of
> this version against Java 8.

I remember we had a similar case years ago when Java 1.4 introduced
StringBuffer.append(StringBuffer) and a release built on 1.4 would no
longer work on 1.3. This is too bad. Can --release fix it only if Java8
is installed (or at least its rt.jar) in additon to the JDK your
building with?

> This mail is just an advance notice to users who might have been
> planning to upgrade their setups to this released version, to wait for a
> newer release,

Sounds as if we should also put that as "news" on the website, on the
home page and into the FAQ (known problems).

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message