ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Drop Support for Java5, Move on to Ant 1.10.0?
Date Sun, 06 Mar 2016 10:12:10 GMT
Hi all

it looks as if we need to make a bunch of changes in order to support
Java9. Right now we can't even bootstrap ant on Java9 without changes
since javac doesn't support -target 1.5 anymore.

I think it's time to drop support for Java5 and - as we've done in the
past - bump the second part of Ant's version number to reflect the
change. We may want to release a final 1.9.7 version, but that would be
a different thread.

I'm not sure whether moving to Java6 is worth the effort since it has
been EOLed as well, even Java7 is no longer officially supported by
Oracle, but personally I wouldn't want to require Java8 right now.

So do we want to move on and if so, what should become our new baseline?

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message