ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antoine Levy Lambert <anto...@gmx.de>
Subject Ant builds in Jenkins
Date Thu, 25 Feb 2016 03:19:40 GMT
Hi,

first I have not been working on Ant at all in the last 12 months or more, I recently changed
job and my current work has been very involving.

I would like to catch up and make a few contributions to Ant and Ivy.

I noticed that the Jenkins builds in JDK 1.5 on Ubuntu are failing [1] , this is due to a
patch recently committed by Stefan [2].

The particular reason why this is failing is that the @Override annotation was not accepted
for interface methods in Java 1.5, see [3].

Let me remove this @Override annotation for now, but maybe we should start discussing about
moving Ant to build only on Java 1.6 and upwards. (and this is being conservative, we could
also consider moving to Java 1.7).

Regards,

Antoine


[1] https://builds.apache.org/job/Ant-Build-Matrix/
[2] https://git1-us-west.apache.org/repos/asf?p=ant.git;a=commitdiff;h=4d0bbb44049a6add8043859c67253545e74c0c3a
[3] http://dertompson.com/2008/01/25/override-specification-changes-in-java-6/
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message