ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: Ant builds in Jenkins
Date Thu, 25 Feb 2016 05:21:16 GMT
On 2016-02-25, Antoine Levy Lambert wrote:

> I would like to catch up and make a few contributions to Ant and Ivy.

great!

> I noticed that the Jenkins builds in JDK 1.5 on Ubuntu are failing [1]
> , this is due to a patch recently committed by Stefan [2].

Oops. Broken Windows. I've gotten so used to Jenkins builds failing
randomly that I've given up looking at the reason. Thanks for catching
that.

> Let me remove this @Override annotation for now,

+1

> but maybe we should start discussing about moving Ant to build only on
> Java 1.6 and upwards. (and this is being conservative, we could also
> consider moving to Java 1.7).

To add another data point: javac of JDK 1.9 doesn't support -target and
-source 1.5 anymore, i.e. you can't build Ant on JDK 1.9 without
changing build.xml.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message