ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: ERROR compile with build.sh, not read the parameters.
Date Mon, 02 Feb 2015 19:51:04 GMT
On 2015-02-02, Rm Beer wrote:

> I use a source code for linux and all settings variable for shell.

> This line put in command shell:

> ./build.sh -Ddist.dir=/src/ant-apache/apache-ant-1.9.4/Build/
> -Xlint:deprecation -Xlint:uncheked

> and getting this result:

> Note: Some input files use or override a deprecated API.
> Note: Recompile with -Xlint:deprecation for details.
> Note: Some input files use unchecked or unsafe operations.
> Note: Recompile with -Xlint:unchecked for details.

> with this finish result:

> /src/ant-apache/apache-ant-1.9.4/src/tests/junit/org/apache/tools/ant/taskdefs/ExecuteWatchdogTest.java:143:
> error: cannot access Matcher
>                         throw new AssumptionViolatedException("process
> interrupted in thread", e);
>                               ^
>   class file for org.hamcrest.Matcher not found

This means Ant hasn't got hamcrest on its classpath, it should be part
of lib/optional after you've run fetch.xml.  Ant ships with junit but
not with hamcrest and it seems we've introduced a dependency on hamcrest
in our core tests - this leads to a bootstrap problem.

Can you bootstrap Ant by running ./bootstrap.sh ?  If so, you can run
the bootstrapped Ant on fetch.xml to pick up the remaining extra jars,
see http://ant.apache.org/manual/install.html#optionalTasks

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message