ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Matèrne (jhm) <apa...@materne.de>
Subject AntUnit @ Jenkins
Date Fri, 06 Jun 2014 06:11:06 GMT
The job is ready.

But the last build gives me an error:

 

https://builds.apache.org/view/A-D/view/Ant/job/AntLib-antunit/lastBuild/con
sole

[au:antunit] Build File:
/x1/jenkins/jenkins-slave/workspace/AntLib-antunit/src/tests/antunit/assertR
esourceExists-test.xml

[au:antunit] Tests run: 4, Failures: 2, Errors: 0, Time elapsed: 0.488 sec

[au:antunit] Target: testURLUsingRef-no  FAILED

[au:antunit]   at line 45, column 59

[au:antunit]   Message: Didn't expect resource 'antsite-foo' to exist

[au:antunit]   took 0.003 sec

[au:antunit] Target: testURL took 0.001 sec

[au:antunit] Target: testURL-no  FAILED

[au:antunit]   at line 37, column 41

[au:antunit]   Message: Didn't expect resource to exist

[au:antunit]   took 0.196 sec

 

The tests check that the given URL does not exist (which gives me a 404 in
the browser and my local au-tests pass).

  <target name="testURL-no"

 
description="https://issues.apache.org/bugzilla/show_bug.cgi?id=53383">

    <au:assertNestedResourceDoesntExist>

      <url url="http://ant.apache.org/foo.html"/>

    </au:assertNestedResourceDoesntExist>

  </target>

 

  <target name="testURLUsingRef-no"

 
description="https://issues.apache.org/bugzilla/show_bug.cgi?id=53383">

    <url url="http://ant.apache.org/foo.html" id="antsite-foo"/>

    <au:assertRefResourceDoesntExist refid="antsite-foo"/>

  </target>

 

Is this related to the Jenkins-environment?

 

Jan

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message