ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Suereth <joshua.suer...@gmail.com>
Subject Re: Ivy tests not passing
Date Mon, 31 Mar 2014 18:28:35 GMT
Ok, I seem to have found the issue.

It appears to test errors, it has Ivy requesting an invalid URL for a given
artifact.   However, the HTML returned by my internet provider is returning
a legitmate document that throws a SAX exception which is uncaught and
bleeds all the way to the test.

Are there any alternative approached for testing the error logs than
attempting to hit a URL?   Is the fact that the SAX exception leaks on a
503 response something I should open as a ticket and resolve?


Thanks!
- Josh


On Sat, Mar 29, 2014 at 1:23 PM, Josh Suereth <joshua.suereth@gmail.com>wrote:

> Well, I tried both master and 2.4, but we should start with master
> (trunk?) I guess:
>
> IBiblioResolverTest.testErrorReport fails with:
>
> The reference to entity "r" must end with the ';' delimiter.
>
> java.text.ParseException: The reference to entity "r" must end with the
> ';' delimiter.
> at
> org.apache.ivy.plugins.parser.m2.PomModuleDescriptorParser.newParserException(PomModuleDescriptorParser.java:375)
> at
> org.apache.ivy.plugins.parser.m2.PomModuleDescriptorParser.parseDescriptor(PomModuleDescriptorParser.java:297)
> at
> org.apache.ivy.plugins.parser.m2.PomModuleDescriptorParser.parseDescriptor(PomModuleDescriptorParser.java:108)
> at
> org.apache.ivy.core.cache.DefaultRepositoryCacheManager$MyModuleDescriptorProvider.provideModule(DefaultRepositoryCacheManager.java:810)
> at
> org.apache.ivy.core.cache.ModuleDescriptorMemoryCache.getStale(ModuleDescriptorMemoryCache.java:68)
> at
> org.apache.ivy.core.cache.DefaultRepositoryCacheManager.getStaledMd(DefaultRepositoryCacheManager.java:827)
> at
> org.apache.ivy.core.cache.DefaultRepositoryCacheManager.cacheModuleDescriptor(DefaultRepositoryCacheManager.java:1319)
> at
> org.apache.ivy.plugins.resolver.BasicResolver.parse(BasicResolver.java:538)
> at
> org.apache.ivy.plugins.resolver.BasicResolver.getDependency(BasicResolver.java:273)
> at
> org.apache.ivy.plugins.resolver.IBiblioResolver.getDependency(IBiblioResolver.java:506)
> at
> org.apache.ivy.plugins.resolver.IBiblioResolverTest.testErrorReport(IBiblioResolverTest.java:251)
> Caused by: org.xml.sax.SAXParseException; systemId:
> file:/home/jsuereth/projects/sbt/ivy/build/cache/org.apache/commons-fileupload/ivy-1.0.xml.original;
> lineNumber: 2; columnNumber: 300; The reference to entity "r" must end with
> the ';' delimiter.
> at org.apache.xerces.parsers.DOMParser.parse(Unknown Source)
> at org.apache.xerces.jaxp.DocumentBuilderImpl.parse(Unknown Source)
> at org.apache.ivy.util.XMLHelper.parseToDom(XMLHelper.java:223)
> at org.apache.ivy.plugins.parser.m2.PomReader.<init>(PomReader.java:122)
> at
> org.apache.ivy.plugins.parser.m2.PomModuleDescriptorParser.parseDescriptor(PomModuleDescriptorParser.java:118)
>
>
> On Fri, Mar 28, 2014 at 7:29 PM, Maarten Coene <maarten_coene@yahoo.com>wrote:
>
>> Hi Josh,
>>
>> The junit tests should all pass when you run them with Ant.
>> On what platform do you run them and what is the error you get?
>>
>> Maarten
>>
>>
>>
>>
>> ________________________________
>>  Van: Josh Suereth <joshua.suereth@gmail.com>
>> Aan: dev@ant.apache.org
>> Verzonden: vrijdag 28 maart 20:48 2014
>> Onderwerp: Ivy tests not passing
>>
>>
>> Hello Ivy Community!
>>
>> I'm Josh Suereth with the sbt build tool.   We've been using Ivy for a few
>> years now, and have recently decided that we'd like to start contributing
>> back some of the usability/performance fixes we have.
>>
>> I'm running into an issue though:  Failing tests.
>>
>> I checked out all the docs I could find, but I don't see how to set up my
>> environment correctly for running tests.  Particularly:
>>
>>
>>    - IBiblioTestResolver.testErrorReport
>>    - Everything that hits the eclipse m2 repository or is related to OSGi
>>
>>
>> Does anyone know where I can look for more information, or does anyone
>> else
>> see the same issues?
>>
>> Note: I'm running off the github fork of the ivy repo.
>>
>>
>> Thanks!
>> - Josh
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message