ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kev Jackson <>
Subject Re: Update [was Re: weblogic rmic]
Date Wed, 07 Nov 2007 03:33:55 GMT

> or we have a vote.
> One thing is clear: weblogic rmic was broken on ant1.7.0. nobody noticed.

Well I've just tested with Ant 1.6.5 (from svn), and I get exactly the 
same error:

      [rmic] RemoteTimestampImpl must be a remote interface 
implementation and should exist in the classpath

The classpath is fine (and the code works perfectly with compiler="sun")

This is the showstopper for an alpha release right now.

This email from 2001 (Ant 1.4) exhibits the exact same behaviour:

Namely, the weblogic rmic task requires a global CLASSPATH to be set.  I 
added a CLASSPATH var and all of a sudden the error disappeared.  I'm 
still not sure it works as I was expecting a WL_stub.class to appear in 
the output directory, but the error went away.

Since this problem seems to have been around for 6+ years now, I vote 
that we switch off these unit tests and move on.

[Vote] WebLogic Rmic tool sucks so:
[X] enough already, we need ant 1.7.1 released regardless of crappy 3rd 
party tools that have never worked properly (update docs to point out 
weblogic rmic glaring incompatibilities with ant, switch off the unit 
test to get a clean build)

[ ] no lets bang our heads against a brick wall for a few more years 
trying to fix this junk


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message